Brad Bishop | 570264f | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor python library" |
| 2 | DESCRIPTION = "Phosphor python library." |
Brad Bishop | 3c69535 | 2016-06-09 01:26:47 -0400 | [diff] [blame] | 3 | HOMEPAGE = "http://github.com/openbmc/pyphosphor" |
Brad Bishop | 570264f | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 7 | |
| 8 | inherit allarch |
| 9 | inherit setuptools |
Brad Bishop | 376b065 | 2016-08-29 21:47:04 -0400 | [diff] [blame^] | 10 | inherit python-dir |
| 11 | |
| 12 | PACKAGE_BEFORE_PN = " \ |
| 13 | ${PN}-ns \ |
| 14 | ${PN}-utils-ns \ |
| 15 | ${PN}-dbus-ns \ |
| 16 | ${PN}-utils \ |
| 17 | ${PN}-dbus \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS_${PN}-utils-ns += "${PN}-ns" |
| 21 | RDEPENDS_${PN}-dbus-ns += "${PN}-ns" |
| 22 | RDEPENDS_${PN}-utils += "${PN}-utils-ns" |
| 23 | RDEPENDS_${PN}-dbus += " \ |
| 24 | ${PN}-dbus-ns \ |
| 25 | python-dbus \ |
| 26 | python-xml \ |
| 27 | python-json \ |
| 28 | python-pickle \ |
| 29 | " |
| 30 | RDEPENDS_${PN} += " \ |
| 31 | ${PN}-ns \ |
| 32 | ${PN}-dbus \ |
| 33 | python-subprocess \ |
| 34 | python-dbus \ |
| 35 | " |
| 36 | |
| 37 | FILES_${PN}-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/__init__.py*" |
| 38 | FILES_${PN}-utils-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/utils/__init__.py*" |
| 39 | FILES_${PN}-dbus-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/dbuslib/__init__.py*" |
| 40 | |
| 41 | FILES_${PN}-utils = "${PYTHON_SITEPACKAGES_DIR}/obmc/utils" |
| 42 | FILES_${PN}-dbus = "${PYTHON_SITEPACKAGES_DIR}/obmc/dbuslib" |
Brad Bishop | 570264f | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 43 | |
| 44 | SRC_URI += "git://github.com/openbmc/pyphosphor" |
| 45 | |
Patrick Williams | 3636259 | 2016-08-22 11:50:08 -0500 | [diff] [blame] | 46 | SRCREV = "ecf8bd8f38d93fda3d08df771709bd5289a480e9" |
Brad Bishop | 570264f | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 47 | |
| 48 | S = "${WORKDIR}/git" |