Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "The upstream project used to drive the Device Mapper multipathing driver" |
| 2 | |
| 3 | DESCRIPTION = "It provides tools to manage multipath devices \ |
| 4 | by instructing the device-mapper kernel module what to do. These \ |
| 5 | tools include: \ |
| 6 | 1. multipath - Scan the system for multipath devices and assemble them.\ |
| 7 | 2. multipathd - Detects when paths fail and execs multipath to update \ |
| 8 | things.\ |
| 9 | 3. mpathpersist - Persistent reservation management feature allows \ |
| 10 | cluster management software to manage persistent reservation through \ |
| 11 | mpath device. It processes management requests from callers and hides \ |
| 12 | the management task details. It also handles persistent reservation \ |
| 13 | management of data path life cycle and state changes.\ |
| 14 | 4. kpartx - This tool, derived from util-linux's partx, reads partition \ |
| 15 | tables on specified device and create device maps over partitions \ |
| 16 | segments detected. It is called from hotplug upon device maps creation \ |
| 17 | and deletion" |
| 18 | |
| 19 | HOMEPAGE = "http://christophe.varoqui.free.fr/" |
| 20 | |
| 21 | DEPENDS = "libdevmapper \ |
| 22 | libaio \ |
| 23 | liburcu \ |
| 24 | readline \ |
| 25 | udev \ |
| 26 | json-c \ |
| 27 | " |
| 28 | |
| 29 | LICENSE = "GPLv2" |
| 30 | |
| 31 | SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http \ |
| 32 | file://multipathd.oe \ |
| 33 | file://multipath.conf.example \ |
| 34 | file://0001-multipath-attempt-at-common-multipath.rules.patch \ |
| 35 | file://0002-RH-fixup-udev-rules-for-redhat.patch \ |
| 36 | file://0003-RH-Remove-the-property-blacklist-exception-builtin.patch \ |
| 37 | file://0004-RH-don-t-start-without-a-config-file.patch \ |
| 38 | file://0005-RH-add-mpathconf.patch \ |
| 39 | file://0006-RH-add-wwids-from-kernel-cmdline-mpath.wwids-with-A.patch \ |
| 40 | file://0007-RH-trigger-change-uevent-on-new-device-creation.patch \ |
| 41 | file://0008-libmultipath-change-how-RADOS-checker-is-enabled.patch \ |
| 42 | file://0009-multipath-set-verbosity-to-default-during-config.patch \ |
| 43 | file://0010-mpath-skip-device-configs-without-vendor-product.patch \ |
| 44 | file://0011-multipathd-fix-show-maps-json-crash.patch \ |
| 45 | file://0012-multipath-tools-modify-Makefile.inc-for-cross-compil.patch \ |
| 46 | file://0013-Always-use-devmapper.patch \ |
| 47 | file://0014-Always-use-devmapper-for-kpartx.patch \ |
| 48 | file://0001-kpartx-include-limits.h-for-PATH_MAX.patch \ |
| 49 | " |
| 50 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 51 | |
| 52 | SRCREV = "f21166a812a2cfb50ecf9550d32947c83103f83a" |
| 53 | |
| 54 | S = "${WORKDIR}/git" |
| 55 | |
| 56 | inherit systemd pkgconfig |
| 57 | |
| 58 | SYSTEMD_SERVICE_${PN} = "multipathd.service" |
| 59 | |
| 60 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 61 | |
| 62 | # multipath-tools includes a copy of the valgrind.h header |
| 63 | # file and uses the macros to suppress some false positives. However, |
| 64 | # that only works on ARM when thumb is disabled. Otherwise one gets: |
| 65 | # Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#3' |
| 66 | # ../Makefile.inc:66: recipe for target 'debug.o' failed |
| 67 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 68 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 69 | |
| 70 | # The exact version of SYSTEMD does not matter but should be greater than 209. |
| 71 | # |
| 72 | EXTRA_OEMAKE = 'MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} \ |
| 73 | OPTFLAGS="${CFLAGS}" \ |
| 74 | bindir=${base_sbindir} \ |
| 75 | LIB=${base_libdir} libdir=${base_libdir}/multipath \ |
| 76 | unitdir=${systemd_system_unitdir} \ |
| 77 | ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "SYSTEMD=216", "", d)} \ |
| 78 | ' |
| 79 | |
| 80 | do_install() { |
| 81 | oe_runmake install |
| 82 | |
| 83 | # We copy an initscript, but do not start multipathd at init time. |
| 84 | # |
| 85 | if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)};then |
| 86 | install -d ${D}${sysconfdir}/init.d |
| 87 | cp ${WORKDIR}/multipathd.oe ${D}${sysconfdir}/init.d/multipathd |
| 88 | fi |
| 89 | |
| 90 | install -d ${D}${sysconfdir} |
| 91 | install -m 0644 ${WORKDIR}/multipath.conf.example \ |
| 92 | ${D}${sysconfdir}/multipath.conf.example |
| 93 | } |
| 94 | |
| 95 | FILES_${PN}-dbg += "${base_libdir}/multipath/.debug" |
| 96 | |
| 97 | PACKAGES =+ "${PN}-libs" |
| 98 | FILES_${PN}-libs = "${base_libdir}/lib*.so.* \ |
| 99 | ${base_libdir}/multipath/lib*.so*" |
| 100 | RDEPENDS_${PN} += "${PN}-libs bash" |
| 101 | |
| 102 | PROVIDES += "device-mapper-multipath" |
| 103 | RPROVIDES_${PN} += "device-mapper-multipath" |
| 104 | RPROVIDES_${PN}-libs += "device-mapper-multipath-libs" |
| 105 | |
| 106 | FILES_${PN}-dev += "${base_libdir}/pkgconfig" |
| 107 | |
| 108 | PACKAGES =+ "kpartx" |
| 109 | FILES_kpartx = "${base_sbindir}/kpartx \ |
| 110 | ${nonarch_libdir}/udev/kpartx_id \ |
| 111 | " |
| 112 | |
| 113 | RDEPENDS_${PN} += "bash kpartx" |