Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | DESCRIPTION = "Security packagegroup for Poky" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \ |
| 4 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 5 | |
| 6 | inherit packagegroup |
| 7 | |
| 8 | PACKAGES = "\ |
| 9 | packagegroup-core-security \ |
| 10 | packagegroup-security-utils \ |
| 11 | packagegroup-security-scanners \ |
| 12 | packagegroup-security-ids \ |
| 13 | packagegroup-security-mac \ |
| 14 | ${@bb.utils.contains("MACHINE_FEATURES", "tpm", "packagegroup-security-tpm", "",d)} \ |
| 15 | " |
| 16 | |
| 17 | RDEPENDS_packagegroup-core-security = "\ |
| 18 | packagegroup-security-utils \ |
| 19 | packagegroup-security-scanners \ |
| 20 | packagegroup-security-ids \ |
| 21 | packagegroup-security-mac \ |
| 22 | ${@bb.utils.contains("MACHINE_FEATURES", "tpm", "packagegroup-security-tpm", "",d)} \ |
| 23 | " |
| 24 | |
| 25 | SUMMARY_packagegroup-security-utils = "Security utilities" |
| 26 | RDEPENDS_packagegroup-security-utils = "\ |
| 27 | checksec \ |
| 28 | nmap \ |
| 29 | pinentry \ |
| 30 | scapy \ |
| 31 | ${@bb.utils.contains("DISTRO_FEATURES", "pax", "pax-utils", "",d)} \ |
| 32 | " |
| 33 | |
| 34 | SUMMARY_packagegroup-security-scanners = "Security scanners" |
| 35 | RDEPENDS_packagegroup-security-scanners = "\ |
| 36 | nikto \ |
| 37 | checksecurity \ |
| 38 | clamav \ |
| 39 | " |
| 40 | |
| 41 | SUMMARY_packagegroup-security-audit = "Security Audit tools " |
| 42 | RDEPENDS_packagegroup-security-audit = " \ |
| 43 | buck-security \ |
| 44 | redhat-security \ |
| 45 | " |
| 46 | |
| 47 | SUMMARY_packagegroup-security-hardening = "Security Hardening tools" |
| 48 | RDEPENDS_packagegroup-security-hardening = " \ |
| 49 | bastille \ |
| 50 | " |
| 51 | |
| 52 | SUMMARY_packagegroup-security-ids = "Security Intrusion Detection systems" |
| 53 | RDEPENDS_packagegroup-security-ids = " \ |
| 54 | tripwire \ |
| 55 | samhain-client \ |
| 56 | suricata \ |
| 57 | " |
| 58 | |
| 59 | SUMMARY_packagegroup-security-mac = "Security Mandatory Access Control systems" |
| 60 | RDEPENDS_packagegroup-security-mac = " \ |
| 61 | ${@bb.utils.contains("DISTRO_FEATURES", "tomoyo", "ccs-tools", "",d)} \ |
| 62 | ${@bb.utils.contains("DISTRO_FEATURES", "apparmor", "", "",d)} \ |
| 63 | ${@bb.utils.contains("DISTRO_FEATURES", "smack", "smack", "",d)} \ |
| 64 | " |