blob: b9cbcf09d0f6e1038682a863d02b2a52b7119112 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Development package for building Applications that use numa"
2HOMEPAGE = "http://oss.sgi.com/projects/libnuma/"
3DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
4to run other programs with a specific NUMA policy and a libnuma to do \
5allocations with NUMA policy in applications."
6LICENSE = "GPL-2.0 & LGPL-2.1"
7SECTION = "apps"
8RDEPENDS_${PN} = "perl"
9
10inherit autotools-brokensep ptest
11
12LIC_FILES_CHKSUM = "file://README;beginline=19;endline=32;md5=5644cc3851cb2499f6c48e52fe198bd9"
13
14SRCREV = "ea3a70681c2f523fe58e1d44527f478ca76db74e"
15PV = "2.0.11+git${SRCPV}"
16
17SRC_URI = "git://github.com/numactl/numactl \
18 file://fix-null-pointer.patch \
19 file://Fix-the-test-output-format.patch \
20 file://Makefile \
21 file://run-ptest \
22 file://0001-define-run-test-target.patch \
23"
24
25S = "${WORKDIR}/git"
26
27# ARM does not currently support NUMA
28COMPATIBLE_HOST = "^((?!arm).*)$"
29
30do_install() {
31 oe_runmake DESTDIR=${D} prefix=${D}/usr install
32 #remove the empty man2 directory
33 rm -r ${D}${mandir}/man2
34}
35
36do_compile_ptest() {
37 oe_runmake test
38}
39
40do_install_ptest() {
41 #install tests binaries
42 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
43 mynode nodemap node-parse pagesize prefered randmap realloc_test \
44 tbitmap tshared"
45
46 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
47 for i in $test_binaries; do
48 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
49 done
50
51 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
52 shmtest runltp bind_range"
53 for i in $test_scripts; do
54 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
55 done
56
57 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
58 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
59}
60
61RDEPENDS_${PN}-ptest = "bash"