Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | require pseudo.inc |
| 2 | |
| 3 | SRC_URI = " \ |
| 4 | http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \ |
| 5 | file://0001-configure-Prune-PIE-flags.patch \ |
| 6 | file://fallback-passwd \ |
| 7 | file://fallback-group \ |
| 8 | file://moreretries.patch \ |
| 9 | file://handle-remove-xattr.patch \ |
| 10 | " |
| 11 | |
| 12 | SRC_URI[md5sum] = "c10209938f03128d0c193f041ff3596d" |
| 13 | SRC_URI[sha256sum] = "fd89cadec984d3b8202aca465898b1bb4350e0d63ba9aa9ac899f6f50270e688" |
| 14 | |
| 15 | PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback" |
| 16 | |
| 17 | do_install_append_class-native () { |
| 18 | install -d ${D}${sysconfdir} |
| 19 | # The fallback files should never be modified |
| 20 | install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd |
| 21 | install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group |
| 22 | } |