blob: b6a4ae773fd9ea16787a1250e968b3ac0264e284 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Count blank lines, comment lines, and physical lines of source code \
2in many programming languages."
3AUTHOR = "Al Danial"
4
5LICENSE="GPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2"
7
8SRC_URI = "https://github.com/AlDanial/cloc/releases/download/${PV}/${BP}.tar.gz"
Andrew Geissler4b7c1152020-11-30 19:55:29 -06009SRC_URI[md5sum] = "9f12f29c824ef61c5eaba6cf2dd6e183"
10SRC_URI[sha256sum] = "e4e30f083bf4e4a5efbe29efa0f6cefa223ba4e841ad1337653ad1f52702dc6f"
Brad Bishope42b3e32020-01-15 22:08:42 -050011
Andrew Geissler82c905d2020-04-13 13:39:40 -050012UPSTREAM_CHECK_URI = "https://github.com/AlDanial/${BPN}/releases"
13
Brad Bishope42b3e32020-01-15 22:08:42 -050014do_configure[noexec] = "1"
15do_compile[noexec] = "1"
16
17do_install() {
18 install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc
19}
20
21RDEPENDS_${PN} = "perl perl-modules"