Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Count blank lines, comment lines, and physical lines of source code \ |
| 2 | in many programming languages." |
| 3 | AUTHOR = "Al Danial" |
| 4 | |
| 5 | LICENSE="GPL-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2" |
| 7 | |
| 8 | SRC_URI = "https://github.com/AlDanial/cloc/releases/download/${PV}/${BP}.tar.gz" |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 9 | SRC_URI[md5sum] = "9f12f29c824ef61c5eaba6cf2dd6e183" |
| 10 | SRC_URI[sha256sum] = "e4e30f083bf4e4a5efbe29efa0f6cefa223ba4e841ad1337653ad1f52702dc6f" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 11 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | UPSTREAM_CHECK_URI = "https://github.com/AlDanial/${BPN}/releases" |
| 13 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 14 | do_configure[noexec] = "1" |
| 15 | do_compile[noexec] = "1" |
| 16 | |
| 17 | do_install() { |
| 18 | install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc |
| 19 | } |
| 20 | |
| 21 | RDEPENDS_${PN} = "perl perl-modules" |