blob: b478e4c58054c04a95b3756305ddc8efda4e3909 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
2HOMEPAGE = "http://www.chronox.de/libkcapi.html"
3LICENSE = "BSD | GPL-2.0"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05004LIC_FILES_CHKSUM = "file://COPYING;md5=c78be93ed8d1637f2a3f4a83ff9d5f54"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005
6DEPENDS = "libtool"
7
8S = "${WORKDIR}/git"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05009SRCREV = "8397f0f7c45264a3b9aff5a1f9119df25eeb4c60"
10SRC_URI = "git://github.com/smuellerDD/libkcapi.git"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
12inherit autotools
13
14PACKAGECONFIG ??= ""
Brad Bishop19323692019-04-05 15:28:33 -040015PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
17
18do_install_append() {
19 # bindir contains testapp and apps. However it is always created, even
20 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
21 rmdir --ignore-fail-on-non-empty ${D}${bindir}
Brad Bishop19323692019-04-05 15:28:33 -040022
23 # Remove the generated binary checksum files
24 rm -f ${D}${bindir}/.*.hmac
25 rm -f ${D}${libdir}/.*.hmac
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026}
27
28CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare"