Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 1 | python __anonymous() { |
| 2 | if "linux-raspberrypi-dev" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"): |
| 3 | msg = "Skipping linux-raspberrypi-dev as it is not the preferred " + \ |
| 4 | "provider of virtual/kernel." |
| 5 | raise bb.parse.SkipRecipe(msg) |
| 6 | } |
| 7 | |
| 8 | FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:" |
| 9 | |
| 10 | LINUX_VERSION ?= "4.11" |
| 11 | LINUX_RPI_DEV_BRANCH ?= "rpi-4.11.y" |
| 12 | |
| 13 | SRCREV = "${AUTOREV}" |
| 14 | SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_DEV_BRANCH} \ |
| 15 | file://0001-build-arm64-Add-rules-for-.dtbo-files-for-dts-overla.patch \ |
| 16 | " |
| 17 | require linux-raspberrypi.inc |
| 18 | |
| 19 | # A LOADADDR is needed when building a uImage format kernel. This value is not |
| 20 | # set by default in rpi-4.8.y and later branches so we need to provide it |
| 21 | # manually. This value unused if KERNEL_IMAGETYPE is not uImage. |
| 22 | KERNEL_EXTRA_ARGS += "LOADADDR=0x00008000" |
| 23 | |
| 24 | # Disable version check so that we don't have to edit this recipe every time |
| 25 | # upstream bumps the version |
| 26 | KERNEL_VERSION_SANITY_SKIP = "1" |