Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 1 | SUMMARY = "A commandline OMX player for the Raspberry Pi" |
| 2 | DESCRIPTION = "This player was developed as a testbed for the XBMC \ |
| 3 | Raspberry PI implementation and is quite handy to use standalone" |
| 4 | HOMEPAGE = "https://github.com/popcornmix/omxplayer" |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 9 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 10 | DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl samba libssh libomxil coreutils-native curl-native" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 11 | PR = "r4" |
| 12 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 13 | SRCREV = "061425a5eabf6e9ee43229911c073a863d144038" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 14 | SRC_URI = "git://github.com/popcornmix/omxplayer.git;protocol=git;branch=master \ |
| 15 | file://0001-Remove-Makefile.include-which-includes-hardcoded.patch \ |
| 16 | file://0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch \ |
| 17 | file://0003-Remove-strip-step-in-Makefile.patch \ |
| 18 | file://0004-Add-FFMPEG_EXTRA_CFLAGS-and-FFMPEG_EXTRA_LDFLAGS.patch \ |
| 19 | file://fix-tar-command-with-DIST.patch \ |
| 20 | file://use-native-pkg-config.patch \ |
| 21 | " |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 24 | COMPATIBLE_MACHINE ?= "null" |
| 25 | COMPATIBLE_MACHINE_rpi_aarch64 = "null" |
| 26 | COMPATIBLE_MACHINE_rpi = "(.*)" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 27 | |
| 28 | inherit autotools-brokensep pkgconfig |
| 29 | |
| 30 | # Needed in ffmpeg configure |
| 31 | export TEMPDIR = "${S}/tmp" |
| 32 | |
| 33 | # Needed in Makefile.ffmpeg |
| 34 | export HOST = "${HOST_SYS}" |
| 35 | export WORK = "${S}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 36 | export FFMPEG_EXTRA_CFLAGS = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}" |
| 37 | export FFMPEG_EXTRA_LDFLAGS = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 38 | |
| 39 | # Needed in top Makefile |
| 40 | export LDFLAGS = "-L${S}/ffmpeg_compiled/usr/lib \ |
| 41 | -L${STAGING_DIR_HOST}/lib \ |
| 42 | -L${STAGING_DIR_HOST}/usr/lib \ |
| 43 | " |
| 44 | export INCLUDES = "-isystem${STAGING_DIR_HOST}/usr/include/interface/vcos/pthreads \ |
| 45 | -isystem${STAGING_DIR_HOST}/usr/include/freetype2 \ |
| 46 | -isystem${STAGING_DIR_HOST}/usr/include/interface/vmcs_host/linux \ |
| 47 | -isystem${STAGING_DIR_HOST}/usr/include/dbus-1.0 \ |
| 48 | -isystem${STAGING_DIR_HOST}/usr/lib/dbus-1.0/include \ |
| 49 | " |
| 50 | export DIST = "${D}" |
| 51 | |
| 52 | do_compile() { |
| 53 | # Needed for compiler test in ffmpeg's configure |
| 54 | mkdir -p tmp |
| 55 | |
| 56 | oe_runmake ffmpeg |
| 57 | oe_runmake |
| 58 | } |
| 59 | |
| 60 | do_install() { |
| 61 | oe_runmake STRIP='echo skipping strip' dist |
| 62 | mkdir -p ${D}${datadir}/fonts/truetype/freefont/ |
| 63 | install ${S}/fonts/* ${D}${datadir}/fonts/truetype/freefont/ |
| 64 | } |
| 65 | |
| 66 | FILES_${PN} = "${bindir}/omxplayer* \ |
| 67 | ${libdir}/omxplayer/lib*${SOLIBS} \ |
| 68 | ${datadir}/fonts" |
| 69 | |
| 70 | FILES_${PN}-dev += "${libdir}/omxplayer/*.so" |
| 71 | |
| 72 | RDEPENDS_${PN} += "bash procps" |