blob: 7aeb5d6c992d950cdbe7f4eb0ba7b6b935690ae6 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "A python library for manipulating kickstart files"
2HOMEPAGE = "http://fedoraproject.org/wiki/pykickstart"
3LICENSE = "GPLv2+"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
6FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
7
8DEPENDS = "python3"
9RDEPENDS_${PN} = "python3 \
10 python3-requests \
11 python3-six \
12"
13
14S = "${WORKDIR}/git"
15SRC_URI = "git://github.com/rhinstaller/pykickstart.git;protocol=https;branch=master \
16 file://0001-support-authentication-for-kickstart.patch \
17 file://0002-pykickstart-parser.py-add-lock-for-readKickstart-and.patch \
18 file://0003-comment-out-sections-shutdown-and-environment-in-gen.patch \
19 file://0004-load.py-retry-to-invoke-request-with-timeout.patch \
20 "
Andrew Geissler748a4832020-07-24 16:24:21 -050021SRCREV = "4c93e84c8798da511da1c05f1912d2f908f8f85f"
Brad Bishop19323692019-04-05 15:28:33 -040022
23UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)"
24
25inherit setuptools3