Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Library to handle input devices in Wayland compositors" |
| 2 | DESCRIPTION = "libinput is a library to handle input devices in Wayland \ |
| 3 | compositors and to provide a generic X.Org input driver. It provides \ |
| 4 | device detection, device handling, input device event processing and \ |
| 5 | abstraction so minimize the amount of custom input code compositors need to \ |
| 6 | provide the common set of functionality that users expect." |
| 7 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=1f2ea9ebff3a2c6d458faf58492efb63" |
| 12 | |
| 13 | DEPENDS = "libevdev udev mtdev" |
| 14 | |
| 15 | SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \ |
| 16 | file://determinism.patch \ |
| 17 | " |
| 18 | SRC_URI[md5sum] = "eb6bd2907ad33d53954d70dfb881a643" |
| 19 | SRC_URI[sha256sum] = "971c3fbfb624f95c911adeb2803c372e4e3647d1b98f278f660051f834597747" |
| 20 | |
| 21 | UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)" |
| 22 | |
| 23 | inherit meson pkgconfig lib_package |
| 24 | |
| 25 | PACKAGECONFIG ??= "" |
| 26 | PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom" |
| 27 | PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3" |
| 28 | |
| 29 | UDEVDIR = "`pkg-config --variable=udevdir udev`" |
| 30 | |
| 31 | EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \ |
| 32 | -Ddocumentation=false \ |
| 33 | -Dtests=false \ |
| 34 | -Dzshcompletiondir=no" |
| 35 | |
| 36 | # package name changed in 1.8.1 upgrade: make sure package upgrades work |
| 37 | RPROVIDES_${PN} = "libinput" |
| 38 | RREPLACES_${PN} = "libinput" |
| 39 | RCONFLICTS_${PN} = "libinput" |
| 40 | |