Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Open Package Manager" |
| 2 | SUMMARY_libopkg = "Open Package Manager library" |
| 3 | SECTION = "base" |
| 4 | HOMEPAGE = "http://code.google.com/p/opkg/" |
| 5 | BUGTRACKER = "http://code.google.com/p/opkg/issues/list" |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 8 | file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0" |
| 9 | |
| 10 | DEPENDS = "libarchive" |
| 11 | |
| 12 | PE = "1" |
| 13 | |
| 14 | SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \ |
| 15 | file://opkg.conf \ |
| 16 | file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \ |
| 17 | file://0001-libopkg-add-add-ignore-recommends-option.patch \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI[md5sum] = "ae51d95fee599bb4dce08453529158f5" |
| 21 | SRC_URI[sha256sum] = "f6c00515d8a2ad8f6742a8e73830315d1983ed0459cba77c4d656cfc9e7fe6fe" |
| 22 | |
| 23 | inherit autotools pkgconfig systemd |
| 24 | |
| 25 | target_localstatedir := "${localstatedir}" |
| 26 | OPKGLIBDIR = "${target_localstatedir}/lib" |
| 27 | |
| 28 | PACKAGECONFIG ??= "libsolv" |
| 29 | |
| 30 | PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg" |
| 31 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl" |
| 32 | PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl" |
| 33 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| 34 | PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256" |
| 35 | PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder" |
| 36 | PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv" |
| 37 | |
| 38 | EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}" |
| 39 | |
| 40 | do_install_append () { |
| 41 | install -d ${D}${sysconfdir}/opkg |
| 42 | install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf |
| 43 | echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf |
| 44 | |
| 45 | # We need to create the lock directory |
| 46 | install -d ${D}${OPKGLIBDIR}/opkg |
| 47 | } |
| 48 | |
| 49 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive" |
| 50 | RDEPENDS_${PN}_class-native = "" |
| 51 | RDEPENDS_${PN}_class-nativesdk = "" |
| 52 | RREPLACES_${PN} = "opkg-nogpg opkg-collateral" |
| 53 | RCONFLICTS_${PN} = "opkg-collateral" |
| 54 | RPROVIDES_${PN} = "opkg-collateral" |
| 55 | |
| 56 | PACKAGES =+ "libopkg" |
| 57 | |
| 58 | FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/" |
| 59 | |
| 60 | BBCLASSEXTEND = "native nativesdk" |
| 61 | |
| 62 | CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf" |