Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/" |
| 3 | LICENSE = "LGPL-2.1+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36" |
| 5 | SECTION = "net" |
| 6 | |
| 7 | DEPENDS = "file" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz \ |
| 10 | " |
| 11 | SRC_URI[md5sum] = "dcd6045ecb4ea18c120afedccbd1da74" |
| 12 | SRC_URI[sha256sum] = "90d0a3d396f96f9bc41eb0f7e8187796049285fabef82604acd4879590977307" |
| 13 | |
| 14 | inherit autotools lib_package pkgconfig gettext |
| 15 | |
| 16 | CFLAGS += "-pthread -D_REENTRANT" |
| 17 | |
| 18 | EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../" |
| 19 | |
| 20 | PACKAGECONFIG ?= "curl https" |
| 21 | PACKAGECONFIG_append_class-target = "\ |
| 22 | ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \ |
| 23 | " |
| 24 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| 25 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," |
| 26 | PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls," |
| 27 | |
| 28 | do_compile_append() { |
| 29 | sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc |
| 30 | } |