blob: 6e73ca74b1f447b66ebef9eaaadd6e0526c4d2ce [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001DESCRIPTION = "This repository contains the source code for the ARM side \
2libraries used on Raspberry Pi. These typically are installed in /opt/vc/lib \
3and includes source for the ARM side code to interface to: EGL, mmal, GLESv2,\
4vcos, openmaxil, vchiq_arm, bcm_host, WFC, OpenVG."
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196"
7
8PR = "r5"
9
10PROVIDES = "virtual/libgles2 \
11 virtual/egl"
12
13RPROVIDES_${PN} += "libgles2 libgl"
14
15COMPATIBLE_MACHINE = "raspberrypi"
16
17SRCBRANCH = "master"
18SRCFORK = "raspberrypi"
19SRCREV = "0147f98bdd4fdc822d25d8a70cf5adc5adb89096"
20
21SRC_URI = "\
22 git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \
23 file://0001-Allow-applications-to-set-next-resource-handle.patch \
24 file://0002-wayland-Add-support-for-the-Wayland-winsys.patch \
25 file://0003-wayland-Add-Wayland-example.patch \
26 file://0004-wayland-egl-Add-bcm_host-to-dependencies.patch \
27 file://0005-interface-remove-faulty-assert-to-make-weston-happy-.patch \
28 file://0006-zero-out-wl-buffers-in-egl_surface_free.patch \
29 file://0007-initialize-front-back-wayland-buffers.patch \
30 file://0008-Remove-RPC_FLUSH.patch \
31 file://0009-fix-cmake-dependency-race.patch \
32 file://0010-Fix-enum-conversion-warnings.patch \
33 file://0011-Fix-for-framerate-with-nested-composition.patch \
34 file://0012-build-shared-library-for-vchostif.patch \
35 file://0013-implement-buffer-wrapping-interface-for-dispmanx.patch \
36"
37S = "${WORKDIR}/git"
38
39inherit cmake pkgconfig
40
41EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' \
42 -DVMCS_INSTALL_PREFIX=${exec_prefix} \
43"
44
45PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
46
47PACKAGECONFIG[wayland] = "-DBUILD_WAYLAND=TRUE -DWAYLAND_SCANNER_EXECUTABLE:FILEPATH=${STAGING_BINDIR_NATIVE}/wayland-scanner,,wayland-native wayland"
48
49CFLAGS_append = " -fPIC"
50
51do_install_append () {
52 for f in `find ${D}${includedir}/interface/vcos/ -name "*.h"`; do
53 sed -i 's/include "vcos_platform.h"/include "pthreads\/vcos_platform.h"/g' ${f}
54 sed -i 's/include "vcos_futex_mutex.h"/include "pthreads\/vcos_futex_mutex.h"/g' ${f}
55 sed -i 's/include "vcos_platform_types.h"/include "pthreads\/vcos_platform_types.h"/g' ${f}
56 done
57}
58
59# Shared libs from userland package build aren't versioned, so we need
60# to force the .so files into the runtime package (and keep them
61# out of -dev package).
62FILES_SOLIBSDEV = ""
63INSANE_SKIP_${PN} += "dev-so"
64
65FILES_${PN} += " \
66 ${libdir}/*.so \
67 ${libdir}/plugins"
68FILES_${PN}-dev += "${includedir} \
69 ${prefix}/src"
70FILES_${PN}-doc += "${datadir}/install"
71FILES_${PN}-dbg += "${libdir}/plugins/.debug"
72
73PACKAGE_ARCH = "${MACHINE_ARCH}"