Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame^] | 1 | SUMMARY = "Linux Console Project" |
| 2 | DESCRIPTION = "This project maintains the Linux Console tools, which include \ |
| 3 | utilities to test and configure joysticks, connect legacy devices to the kernel's \ |
| 4 | input subsystem (providing support for serial mice, touchscreens etc.), and test \ |
| 5 | the input event layer." |
| 6 | HOMEPAGE = "https://sourceforge.net/projects/linuxconsole" |
| 7 | |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 10 | |
| 11 | DEPENDS = "libsdl2" |
| 12 | DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 13 | |
| 14 | SRC_URI = "\ |
| 15 | ${SOURCEFORGE_MIRROR}/linuxconsole/linuxconsoletools-${PV}.tar.bz2 \ |
| 16 | file://51-these-are-not-joysticks-rm.rules \ |
| 17 | file://60-joystick.rules \ |
| 18 | file://inputattachctl \ |
| 19 | file://inputattach.service \ |
| 20 | " |
| 21 | |
| 22 | SRC_URI[sha256sum] = "95d112f06393806116341d593bda002c8bc44119c1538407623268fed90d8c34" |
| 23 | |
| 24 | S = "${WORKDIR}/linuxconsoletools-${PV}" |
| 25 | |
| 26 | inherit systemd pkgconfig |
| 27 | |
| 28 | EXTRA_OEMAKE = "DESTDIR=${D} PREFIX=${prefix} -C utils" |
| 29 | EXTRA_OEMAKE += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'SYSTEMD_SUPPORT=1', '', d)}" |
| 30 | |
| 31 | SYSTEMD_PACKAGES += "inputattach" |
| 32 | SYSTEMD_SERVICE_inputattach = "inputattach.service" |
| 33 | SYSTEMD_AUTO_ENABLE_inputattach = "enable" |
| 34 | |
| 35 | do_compile() { |
| 36 | oe_runmake |
| 37 | } |
| 38 | |
| 39 | do_install() { |
| 40 | oe_runmake install |
| 41 | |
| 42 | install -Dm 0644 ${WORKDIR}/51-these-are-not-joysticks-rm.rules ${D}${base_libdir}/udev/rules.d/51-these-are-not-joysticks-rm.rules |
| 43 | install -Dm 0644 ${WORKDIR}/60-joystick.rules ${D}${base_libdir}/udev/rules.d/60-joystick.rules |
| 44 | |
| 45 | install -Dm 0644 ${WORKDIR}/inputattach.service ${D}${systemd_system_unitdir}/inputattach.service |
| 46 | install -Dm 0755 ${WORKDIR}/inputattachctl ${D}${bindir}/inputattachctl |
| 47 | } |
| 48 | |
| 49 | PACKAGES += "inputattach joystick" |
| 50 | |
| 51 | # We won't package any file here as we are following the same packaging schema |
| 52 | # Debian does and we are splitting it in 'inputattach' and 'joystick' packages. |
| 53 | FILES_${PN} = "" |
| 54 | |
| 55 | FILES_inputattach += "\ |
| 56 | ${bindir}/inputattach \ |
| 57 | ${bindir}/inputattachctl \ |
| 58 | ${systemd_system_unitdir}/inputattach.service \ |
| 59 | " |
| 60 | |
| 61 | FILES_joystick += "\ |
| 62 | ${bindir}/evdev-joystick \ |
| 63 | ${bindir}/ffcfstress \ |
| 64 | ${bindir}/ffmvforce \ |
| 65 | ${bindir}/ffset \ |
| 66 | ${bindir}/fftest \ |
| 67 | ${bindir}/jscal \ |
| 68 | ${bindir}/jscal-restore \ |
| 69 | ${bindir}/jscal-store \ |
| 70 | ${bindir}/jstest \ |
| 71 | ${datadir}/joystick \ |
| 72 | ${base_libdir}/udev/rules.d/51-these-are-not-joysticks-rm.rules \ |
| 73 | ${base_libdir}/udev/js-set-enum-leds \ |
| 74 | ${base_libdir}/udev/rules.d/60-joystick.rules \ |
| 75 | ${base_libdir}/udev/rules.d/80-stelladaptor-joystick.rules \ |
| 76 | " |
| 77 | |
| 78 | RDEPENDS_inputattach += "inputattach-config" |
| 79 | |
| 80 | RDEPENDS_joystick += "\ |
| 81 | bash \ |
| 82 | gawk \ |
| 83 | " |