Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \ |
| 2 | block devices. It has a plugin-based architecture where each technology (like \ |
| 3 | LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \ |
| 4 | with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)." |
| 5 | HOMEPAGE = "http://rhinstaller.github.io/libblockdev/" |
| 6 | LICENSE = "LGPLv2+" |
| 7 | SECTION = "devel/lib" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c" |
| 10 | |
| 11 | inherit autotools python3native gobject-introspection |
| 12 | |
| 13 | DEPENDS += " \ |
| 14 | cryptsetup \ |
| 15 | nss \ |
| 16 | volume-key \ |
| 17 | libbytesize \ |
| 18 | btrfs-tools \ |
| 19 | " |
| 20 | |
| 21 | SRCREV = "e2e0899efe8dd3f111ff955fb6c1dc10b0bd2075" |
| 22 | SRC_URI = " \ |
| 23 | git://github.com/rhinstaller/libblockdev;branch=master \ |
| 24 | file://0001-fix-configure-and-compile-failures.patch \ |
| 25 | file://0002-remove-python2-support.patch \ |
| 26 | file://0003-remove-dmraid-while-compiling-with-with-dm.patch \ |
| 27 | file://0005-fix-a-clang-compiling-issue.patch \ |
| 28 | " |
| 29 | SRC_URI_append_libc-musl = " \ |
| 30 | file://0004-fix-compile-failure-against-musl-C-library.patch \ |
| 31 | " |
| 32 | |
| 33 | S = "${WORKDIR}/git" |
| 34 | |
| 35 | RDEPENDS_${PN} += " \ |
| 36 | lvm2 \ |
| 37 | " |
| 38 | |
| 39 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
| 40 | |
| 41 | PACKAGECONFIG ??= "python3 lvm dm kmod parted fs" |
| 42 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" |
| 43 | PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools" |
| 44 | PACKAGECONFIG[dm] = "--with-dm, --without-dm" |
| 45 | PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod" |
| 46 | PACKAGECONFIG[parted] = "--with-part, --without-part, parted" |
| 47 | PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux" |
| 48 | PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native" |
| 49 | |
| 50 | export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs" |
| 51 | |