blob: 999496273c0219e7358af3ecc1311e8c4a2aaaa2 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Brad Bishop96ff1982019-08-19 13:50:42 -04008 file://CVE-2019-6128.patch \
9 file://CVE-2019-7663.patch"
Brad Bishop19323692019-04-05 15:28:33 -040010SRC_URI[md5sum] = "114192d7ebe537912a2b97408832e7fd"
11SRC_URI[sha256sum] = "2c52d11ccaf767457db0c46795d9c7d1a8d8f76f68b0b800a3dfe45786b996e4"
12
13# exclude betas
14UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
15
16inherit autotools multilib_header
17
18CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
19
20PACKAGECONFIG ?= "cxx jpeg zlib lzma \
21 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
22
23PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
24PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
25PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
26PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
27
28# Convert single-strip uncompressed images to multiple strips of specified
29# size (default: 8192) to reduce memory usage
30PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
31
32# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
33PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
34
35# Control picking up YCbCr subsample info. Disable to support files lacking
36# the tag
37PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
38
39# Support a mechanism allowing reading large strips (usually one strip files)
40# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
41PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
42
43PACKAGES =+ "tiffxx tiff-utils"
44FILES_tiffxx = "${libdir}/libtiffxx.so.*"
45FILES_tiff-utils = "${bindir}/*"
46
47do_install_append() {
48 oe_multilib_header tiffconf.h
49}
50
51BBCLASSEXTEND = "native"