Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
| 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome/libs" |
| 5 | LICENSE = "LGPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 7 | |
| 8 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native" |
| 9 | |
| 10 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 11 | |
| 12 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz" |
| 13 | SRC_URI[md5sum] = "dfbf30af5fb6190bfafc5aa6abcc9dce" |
| 14 | SRC_URI[sha256sum] = "d312ade547495c2093ff8bda61f9b9727a98cfdae339f3263277dd39c0451172" |
| 15 | |
| 16 | S = "${WORKDIR}/libsoup-${PV}" |
| 17 | |
| 18 | inherit autotools gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| 19 | |
| 20 | # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default. |
| 21 | PACKAGECONFIG ??= "" |
| 22 | PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome" |
| 23 | PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5" |
| 24 | |
| 25 | EXTRA_OECONF = "--disable-vala" |
| 26 | |
| 27 | # When built without gnome support, libsoup-2.4 will contain only one shared lib |
| 28 | # and will therefore become subject to renaming by debian.bbclass. Prevent |
| 29 | # renaming in order to keep the package name consistent regardless of whether |
| 30 | # gnome support is enabled or disabled. |
| 31 | DEBIAN_NOAUTONAME_${PN} = "1" |
| 32 | |
| 33 | # glib-networking is needed for SSL, proxies, etc. |
| 34 | RRECOMMENDS_${PN} = "glib-networking" |