Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | # |
| 2 | # Copyright (C) 2010 Intel Corporation. All rights reserved |
| 3 | # |
| 4 | |
| 5 | SUMMARY = "Qt package groups" |
| 6 | LICENSE = "MIT" |
| 7 | PR = "r4" |
| 8 | |
| 9 | # Qt4 could NOT be built on MIPS64 with 64 bits userspace |
| 10 | COMPATIBLE_HOST_mips64 = "null" |
| 11 | |
| 12 | inherit packagegroup distro_features_check |
| 13 | |
| 14 | # The quicky and fotowall requires x11 in DISTRO_FEATURES |
| 15 | REQUIRED_DISTRO_FEATURES = "x11" |
| 16 | |
| 17 | PACKAGES = "${PN}-demoapps" |
| 18 | |
| 19 | QTDEMOS ?= "quicky ${COMMERCIAL_QT} fotowall" |
| 20 | |
| 21 | SUMMARY_${PN}-demoapps = "Qt demo applications" |
| 22 | RDEPENDS_${PN}-demoapps = "${QTDEMOS}" |