blob: a804b0cc00c663a45c2974963ac02322c1065716 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python WBEM Client and Provider Interface"
2DESCRIPTION = "\
3A Python library for making CIM (Common Information Model) operations over \
4HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \
5WBEM client should be easy to use and not necessarily require a large amount \
6of programming knowledge. It is suitable for a large range of tasks from \
7simply poking around to writing web and GUI applications. \
8\
9WBEM, or Web Based Enterprise Management is a manageability protocol, like \
10SNMP, standardised by the Distributed Management Task Force (DMTF) available \
11at http://www.dmtf.org/standards/wbem. \
12\
13It also provides a Python provider interface, and is the fastest and easiest \
14way to write providers on the planet."
15HOMEPAGE = "http://pywbem.github.io"
16LICENSE = "LGPLv2.1"
Brad Bishope42b3e32020-01-15 22:08:42 -050017LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050019SRC_URI[md5sum] = "b65c03026bf2174e58e3e47a5e7e4825"
20SRC_URI[sha256sum] = "5b54b65a5434bb16432415743c0d154feee0c6d7a8a2fee208719c67d6d24c97"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
Andrew Geisslerd221e032020-07-10 16:13:21 -050022inherit pypi setuptools3 update-alternatives
Brad Bishope42b3e32020-01-15 22:08:42 -050023
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024DEPENDS += " \
25 ${PYTHON_PN}-ply-native \
26 ${PYTHON_PN}-pyyaml-native \
27 ${PYTHON_PN}-six-native \
28"
29
30do_install_append() {
31 mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli
32
33 rm -f ${D}${bindir}/*.bat
34}
35
36RDEPENDS_${PN}_class-target += "\
37 ${PYTHON_PN}-datetime \
38 ${PYTHON_PN}-io \
39 ${PYTHON_PN}-netclient \
40 ${PYTHON_PN}-ply \
41 ${PYTHON_PN}-pyyaml \
42 ${PYTHON_PN}-six \
43 ${PYTHON_PN}-stringold \
44 ${PYTHON_PN}-threading \
45 ${PYTHON_PN}-unixadmin \
46 ${PYTHON_PN}-xml \
47"
48
Andrew Geisslerd221e032020-07-10 16:13:21 -050049ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli"
50ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
51ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
52ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
53
54ALTERNATIVE_PRIORITY = "60"
55
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080056BBCLASSEXTEND = "native"