Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Python WBEM Client and Provider Interface" |
| 2 | DESCRIPTION = "\ |
| 3 | A Python library for making CIM (Common Information Model) operations over \ |
| 4 | HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \ |
| 5 | WBEM client should be easy to use and not necessarily require a large amount \ |
| 6 | of programming knowledge. It is suitable for a large range of tasks from \ |
| 7 | simply poking around to writing web and GUI applications. \ |
| 8 | \ |
| 9 | WBEM, or Web Based Enterprise Management is a manageability protocol, like \ |
| 10 | SNMP, standardised by the Distributed Management Task Force (DMTF) available \ |
| 11 | at http://www.dmtf.org/standards/wbem. \ |
| 12 | \ |
| 13 | It also provides a Python provider interface, and is the fastest and easiest \ |
| 14 | way to write providers on the planet." |
| 15 | HOMEPAGE = "http://pywbem.github.io" |
| 16 | LICENSE = "LGPLv2.1" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 17 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 19 | SRC_URI[md5sum] = "b65c03026bf2174e58e3e47a5e7e4825" |
| 20 | SRC_URI[sha256sum] = "5b54b65a5434bb16432415743c0d154feee0c6d7a8a2fee208719c67d6d24c97" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 22 | inherit pypi setuptools3 update-alternatives |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 23 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | DEPENDS += " \ |
| 25 | ${PYTHON_PN}-ply-native \ |
| 26 | ${PYTHON_PN}-pyyaml-native \ |
| 27 | ${PYTHON_PN}-six-native \ |
| 28 | " |
| 29 | |
| 30 | do_install_append() { |
| 31 | mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli |
| 32 | |
| 33 | rm -f ${D}${bindir}/*.bat |
| 34 | } |
| 35 | |
| 36 | RDEPENDS_${PN}_class-target += "\ |
| 37 | ${PYTHON_PN}-datetime \ |
| 38 | ${PYTHON_PN}-io \ |
| 39 | ${PYTHON_PN}-netclient \ |
| 40 | ${PYTHON_PN}-ply \ |
| 41 | ${PYTHON_PN}-pyyaml \ |
| 42 | ${PYTHON_PN}-six \ |
| 43 | ${PYTHON_PN}-stringold \ |
| 44 | ${PYTHON_PN}-threading \ |
| 45 | ${PYTHON_PN}-unixadmin \ |
| 46 | ${PYTHON_PN}-xml \ |
| 47 | " |
| 48 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 49 | ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli" |
| 50 | ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler" |
| 51 | ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli" |
| 52 | ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli" |
| 53 | |
| 54 | ALTERNATIVE_PRIORITY = "60" |
| 55 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 56 | BBCLASSEXTEND = "native" |