blob: ff05227aa6bb4f090ff448bd6a26492f38277014 [file] [log] [blame]
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05001SUMMARY = "C-Periphery lib used to access GPIO, LED, PWM, SPI, I2C, MMIO, Serial"
Andrew Geissler89770b02020-06-13 10:40:47 -05002DESCRIPTION = "A C library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux"
3
4HOMEPAGE = "https://github.com/vsergeev/c-periphery"
5
6SECTION = "libs"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=4097ec544cf01e9c7cfc4bdf8e4ed887"
10
11SRC_URI = "git://github.com/vsergeev/c-periphery;protocol=https"
Andrew Geissler8fc454f2020-12-11 16:27:59 -060012SRCREV = "513f5edbcf2f2ec5c0cd711d1cc312eb2d753f1b"
Andrew Geissler89770b02020-06-13 10:40:47 -050013
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
19
20BBCLASSEXTEND = "native nativesdk"
21