Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "The Open Container Initiative develops specifications for standards on Operating System process and application containers" |
| 2 | HOMEPAGE = "https://github.com/opencontainers/runtime-spec" |
| 3 | SECTION = "devel/go" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=b355a61a394a504dacde901c958f662c" |
| 6 | |
| 7 | SRCNAME = "runtime-spec" |
| 8 | |
| 9 | PKG_NAME = "github.com/opencontainers/${SRCNAME}" |
| 10 | SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}" |
| 11 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | SRCREV = "a39b1cd4fdf7743ab721cc9da58abbee2f8624d1" |
| 13 | PV = "v1.0.0-rc6+git${SRCPV}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | # NO-OP the do compile rule because this recipe is source only. |
| 18 | do_compile() { |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} |
| 23 | for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go" -not -path "*/.tool/*"); do |
| 24 | if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then |
| 25 | mkdir -p ${D}${prefix}/local/go/$(dirname $j) |
| 26 | fi |
| 27 | cp $j ${D}${prefix}/local/go/$j |
| 28 | done |
| 29 | cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/ |
| 30 | } |
| 31 | |
| 32 | SYSROOT_PREPROCESS_FUNCS += "runtime_spec_file_sysroot_preprocess" |
| 33 | |
| 34 | runtime_spec_file_sysroot_preprocess () { |
| 35 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} |
| 36 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) |
| 37 | } |
| 38 | |
| 39 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" |
| 40 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 41 | CLEANBROKEN = "1" |