Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | require libgpiod.inc |
| 2 | |
| 3 | DEPENDS += "autoconf-archive-native" |
| 4 | |
| 5 | SRC_URI[md5sum] = "d4826720a8de13379436f9c207237bc0" |
| 6 | SRC_URI[sha256sum] = "0ad080d1eb89c422cf13001293ffa72869ca13028e85dab5f6b3ba90f88da46d" |
| 7 | |
| 8 | # enable cxx bindings |
| 9 | PACKAGECONFIG ?= "cxx" |
| 10 | |
| 11 | PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" |
| 12 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" |
| 13 | |
| 14 | PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3" |
| 15 | |
| 16 | inherit python3native |
| 17 | |
| 18 | PACKAGES =+ "${PN}-python" |
| 19 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |
| 20 | RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}" |
| 21 | RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}" |