blob: cf4de22c4744aca3ad5216063487508eb5e8ba1e [file] [log] [blame]
Brad Bishop08902b02019-08-20 09:16:51 -04001SUMMARY = "A library providing C and Python (libcURL like) API \
2 for downloading linux repository metadata and packages."
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6SRC_URI = "git://github.com/rpm-software-management/librepo.git \
7 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
8 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
9 "
10
Brad Bishopf3f93bb2019-10-16 14:33:32 -040011SRCREV = "2ec349f1c686c1704dc83da6c118035ff57c8dea"
Brad Bishop08902b02019-08-20 09:16:51 -040012
13S = "${WORKDIR}/git"
14
15DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
16
17inherit cmake distutils3-base pkgconfig
18
19EXTRA_OECMAKE = " \
20 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
21 -DPYTHON_DESIRED=3 \
22 -DENABLE_TESTS=OFF \
23 -DENABLE_DOCS=OFF \
24 -DWITH_ZCHUNK=OFF \
25"
26
27BBCLASSEXTEND = "native nativesdk"