Add support for using the hcode repo

    -Add hcode package to enable compiling hardware
     reference image
    -Modify pnor and sbe makefiles to include a dependency on
     the hcode repository
    -Modify config files so that p9 platfoms use the compiled
     version of the hardware reference image by default
    -Update hostboot-binaries.mk to install the ring images
     to the staging dir

[stewart: remove IBM Austin specific paths, update defconfigs]
Signed-off-by: Stewart Smith <stewart@linux.ibm.com>
diff --git a/openpower/package/hostboot-binaries/hostboot_binaries.mk b/openpower/package/hostboot-binaries/hostboot_binaries.mk
index 5a97bd7..4e4b04e 100644
--- a/openpower/package/hostboot-binaries/hostboot_binaries.mk
+++ b/openpower/package/hostboot-binaries/hostboot_binaries.mk
@@ -14,6 +14,9 @@
 HOSTBOOT_BINARIES_INSTALL_IMAGES = YES
 HOSTBOOT_BINARIES_INSTALL_TARGET = NO
 
+NIMBUS_RING_FILE=p9n.hw.rings.bin
+NIMBUS_RING_OVERLAYS_FILE=p9n.hw.overlays.bin
+
 #for P9 the hw_ref image is changing to not be padded with ECC.  However
 #all the other op-build files use the end name result.  Thus replace ".hdr.bin.ecc"
 #with ".bin"
@@ -25,6 +28,9 @@
      $(INSTALL) -D $(@D)/$(BR2_HOSTBOOT_BINARY_SBEC_FILENAME) $(STAGING_DIR)/hostboot_binaries/
      $(INSTALL) -D $(@D)/$(BR2_HOSTBOOT_BINARY_SBE_FILENAME)  $(STAGING_DIR)/hostboot_binaries/
      $(INSTALL) -D $(@D)/gpu_gpe1.bin  $(STAGING_DIR)/hostboot_binaries/gpu_gpe1.bin
+     $(INSTALL) -D $(@D)/$(NIMBUS_RING_FILE)  $(STAGING_DIR)/hostboot_binaries/
+     $(INSTALL) -D $(@D)/$(NIMBUS_RING_OVERLAYS_FILE)  $(STAGING_DIR)/hostboot_binaries/
+     $(INSTALL) -D $(@D)/$(BR2_HOSTBOOT_BINARY_IONV_FILENAME)  $(STAGING_DIR)/hostboot_binaries/
 endef
 
 $(eval $(generic-package))