blob: cf8ac73834ea8bde4f76cc603668392731cb5e6e [file] [log] [blame]
Matt Ploetzc19ce762016-09-01 18:18:56 -05001################################################################################
2#
3# ppe42-gcc
4#
5################################################################################
6
7PPE42_GCC_VERSION ?= 246277a8513f622a65f97cb59e3079fc8834a913
8PPE42_GCC_SITE ?= $(call github,open-power,ppe42-gcc,$(PPE42_GCC_VERSION))
9PPE42_GCC_LICENSE = GPLv3+
10
11PPE42_GCC_DEPENDENCIES = ppe42-binutils
12
13PPE42_GCC_DIR = $(STAGING_DIR)/ppe42-binutils
14PPE42_GCC_BIN = $(STAGING_DIR)/ppe42-binutils/linux
15
16define HOST_PPE42_GCC_BUILD_CMDS
17 cd $(@D) && \
18 ./configure --prefix=$(PPE42_GCC_DIR) \
19 --exec-prefix=$(PPE42_GCC_BIN) \
20 --target=powerpc-eabi \
21 --without-headers \
22 --with-newlib \
23 --with-gnu-as \
24 --with-gnu-ld \
25 --with-gmp=$(HOST_DIR)/usr \
26 --with-mpfr=$(HOST_DIR)/usr \
27 && \
28 make configure-host && \
29 make all-gcc
30endef
31
32define HOST_PPE42_GCC_INSTALL_CMDS
33 bash -c 'cd $(@D) && make install-gcc'
34endef
35
36$(eval $(host-generic-package))