blob: 79955eaa67a34d269d49c140030e2945a8c77333 [file] [log] [blame]
Matt Ploetzd8ee69a2016-08-26 12:45:30 -05001################################################################################
2#
3# witherspoon_xml
4#
5################################################################################
6
Prachi Gupta6aabb9e2016-11-17 17:20:48 -06007WITHERSPOON_XML_VERSION ?= 3a89d5efc33377302418c06d654cc3356561c797
Matt Ploetzd8ee69a2016-08-26 12:45:30 -05008WITHERSPOON_XML_SITE ?= $(call github,open-power,witherspoon-xml,$(WITHERSPOON_XML_VERSION))
9
10WITHERSPOON_XML_LICENSE = Apache-2.0
11WITHERSPOON_XML_DEPENDENCIES = hostboot-install-images openpower-mrw-install-images common-p8-xml-install-images
12
13WITHERSPOON_XML_INSTALL_IMAGES = YES
14WITHERSPOON_XML_INSTALL_TARGET = YES
15
16MRW_SCRATCH=$(STAGING_DIR)/openpower_mrw_scratch
17MRW_HB_TOOLS=$(STAGING_DIR)/hostboot_build_images
18
19# Defines for BIOS metadata creation
20BIOS_SCHEMA_FILE = $(MRW_HB_TOOLS)/bios.xsd
21WITHERSPOON_BIOS_XML_CONFIG_FILE = $(MRW_SCRATCH)/$(BR2_WITHERSPOON_BIOS_XML_FILENAME)
22BIOS_XML_METADATA_FILE = \
23 $(MRW_HB_TOOLS)/$(BR2_OPENPOWER_CONFIG_NAME)_bios_metadata.xml
24PETITBOOT_XSLT_FILE = $(MRW_HB_TOOLS)/bios_metadata_petitboot.xslt
25PETITBOOT_BIOS_XML_METADATA_FILE = \
26 $(MRW_HB_TOOLS)/$(BR2_OPENPOWER_CONFIG_NAME)_bios_metadata_petitboot.xml
27PETITBOOT_BIOS_XML_METADATA_INITRAMFS_FILE = \
28 $(TARGET_DIR)/usr/share/bios_metadata.xml
29
30define WITHERSPOON_XML_BUILD_CMDS
31 # copy the witherspoon xml where the common lives
32 bash -c 'mkdir -p $(MRW_SCRATCH) && cp -r $(@D)/* $(MRW_SCRATCH)'
33
34 # generate the system mrw xml
Prachi Gupta6aabb9e2016-11-17 17:20:48 -060035 perl -I $(MRW_HB_TOOLS) \
Matt Ploetzd8ee69a2016-08-26 12:45:30 -050036 $(MRW_HB_TOOLS)/processMrw.pl -x $(MRW_SCRATCH)/witherspoon.xml
Matt Ploetzeee3d752016-09-28 17:10:09 -050037
Matt Ploetzd8ee69a2016-08-26 12:45:30 -050038 # merge in any system specific attributes, hostboot attributes
39 $(MRW_HB_TOOLS)/mergexml.sh $(MRW_SCRATCH)/$(BR2_WITHERSPOON_SYSTEM_XML_FILENAME) \
40 $(MRW_HB_TOOLS)/attribute_types.xml \
41 $(MRW_HB_TOOLS)/attribute_types_hb.xml \
42 $(MRW_HB_TOOLS)/target_types_merged.xml \
43 $(MRW_HB_TOOLS)/target_types_hb.xml \
44 $(MRW_SCRATCH)/$(BR2_WITHERSPOON_MRW_XML_FILENAME) > $(MRW_HB_TOOLS)/temporary_hb.hb.xml;
45
46 # creating the targeting binary
47 $(MRW_HB_TOOLS)/xmltohb.pl \
48 --hb-xml-file=$(MRW_HB_TOOLS)/temporary_hb.hb.xml \
49 --fapi-attributes-xml-file=$(MRW_HB_TOOLS)/fapiattrs.xml \
50 --src-output-dir=none \
51 --img-output-dir=$(MRW_HB_TOOLS)/ \
52 --vmm-consts-file=$(MRW_HB_TOOLS)/vmmconst.h --noshort-enums \
53 --bios-xml-file=$(WITHERSPOON_BIOS_XML_CONFIG_FILE) \
54 --bios-schema-file=$(BIOS_SCHEMA_FILE) \
55 --bios-output-file=$(BIOS_XML_METADATA_FILE)
56
57 # Transform BIOS XML into Petitboot specific BIOS XML via the schema
58 xsltproc -o \
59 $(PETITBOOT_BIOS_XML_METADATA_FILE) \
60 $(PETITBOOT_XSLT_FILE) \
61 $(BIOS_XML_METADATA_FILE)
62endef
63
64define WITHERSPOON_XML_INSTALL_IMAGES_CMDS
65 mv $(MRW_HB_TOOLS)/targeting.bin $(MRW_HB_TOOLS)/$(BR2_OPENPOWER_TARGETING_BIN_FILENAME)
66endef
67
68define WITHERSPOON_XML_INSTALL_TARGET_CMDS
69 # Install Petitboot specific BIOS XML into initramfs's usr/share/ dir
70 $(INSTALL) -D -m 0644 \
71 $(PETITBOOT_BIOS_XML_METADATA_FILE) \
72 $(PETITBOOT_BIOS_XML_METADATA_INITRAMFS_FILE)
73endef
74
75$(eval $(generic-package))