blob: 52c885002601b9f16c748c49ba91506db11eb7b9 [file] [log] [blame]
Robert Lippertaed5d2b2016-11-22 16:32:06 -08001################################################################################
2#
3# zaius_xml
4#
5################################################################################
6
hostboot9c0767d2017-02-07 00:05:54 -06007ZAIUS_XML_VERSION ?= 365f04dafc0a79f56b1a91b65b23571183ce1645
Robert Lippert58a08b42016-12-22 11:44:06 -08008ZAIUS_XML_SITE ?= $(call github,open-power,zaius-xml,$(ZAIUS_XML_VERSION))
Robert Lippertaed5d2b2016-11-22 16:32:06 -08009
10ZAIUS_XML_LICENSE = Apache-2.0
11ZAIUS_XML_DEPENDENCIES = hostboot-install-images openpower-mrw-install-images common-p8-xml-install-images
12
13ZAIUS_XML_INSTALL_IMAGES = YES
14ZAIUS_XML_INSTALL_TARGET = YES
15
16MRW_SCRATCH=$(STAGING_DIR)/openpower_mrw_scratch
17MRW_HB_TOOLS=$(STAGING_DIR)/hostboot_build_images
18
19# Defines for BIOS metadata creation
20BIOS_SCHEMA_FILE = $(MRW_HB_TOOLS)/bios.xsd
21ZAIUS_BIOS_XML_CONFIG_FILE = $(MRW_SCRATCH)/$(BR2_ZAIUS_BIOS_XML_FILENAME)
22BIOS_XML_METADATA_FILE = \
23 $(MRW_HB_TOOLS)/$(BR2_OPENPOWER_CONFIG_NAME)_bios_metadata.xml
24PETITBOOT_XSLT_FILE = $(MRW_HB_TOOLS)/bios_metadata_petitboot.xslt
25PETITBOOT_BIOS_XML_METADATA_FILE = \
26 $(MRW_HB_TOOLS)/$(BR2_OPENPOWER_CONFIG_NAME)_bios_metadata_petitboot.xml
27PETITBOOT_BIOS_XML_METADATA_INITRAMFS_FILE = \
28 $(TARGET_DIR)/usr/share/bios_metadata.xml
29
30define ZAIUS_XML_BUILD_CMDS
31 # copy the zaius xml where the common lives
32 bash -c 'mkdir -p $(MRW_SCRATCH) && cp -r $(@D)/* $(MRW_SCRATCH)'
33
34 # generate the system mrw xml
35 perl -I $(MRW_HB_TOOLS) \
36 $(MRW_HB_TOOLS)/processMrw.pl -x $(MRW_SCRATCH)/zaius.xml
37
Robert Lippert851e4c32016-12-19 12:31:25 -080038 # filter out unwanted attributes
39 chmod +x $(MRW_HB_TOOLS)/filter_out_unwanted_attributes.pl
40
41 $(MRW_HB_TOOLS)/filter_out_unwanted_attributes.pl \
42 --tgt-xml $(MRW_HB_TOOLS)/target_types_merged.xml \
43 --tgt-xml $(MRW_HB_TOOLS)/target_types_hb.xml \
44 --tgt-xml $(MRW_HB_TOOLS)/target_types_oppowervm.xml \
Elizabeth Linerc0a38d72017-02-08 21:01:08 -060045 --tgt-xml $(MRW_HB_TOOLS)/target_types_openpower.xml \
Robert Lippert851e4c32016-12-19 12:31:25 -080046 --mrw-xml $(MRW_SCRATCH)/$(BR2_ZAIUS_MRW_XML_FILENAME)
47
48 cp $(MRW_SCRATCH)/$(BR2_ZAIUS_MRW_XML_FILENAME).updated \
49 $(MRW_SCRATCH)/$(BR2_ZAIUS_MRW_XML_FILENAME)
50
Robert Lippertaed5d2b2016-11-22 16:32:06 -080051 # merge in any system specific attributes, hostboot attributes
52 $(MRW_HB_TOOLS)/mergexml.sh $(MRW_SCRATCH)/$(BR2_ZAIUS_SYSTEM_XML_FILENAME) \
53 $(MRW_HB_TOOLS)/attribute_types.xml \
54 $(MRW_HB_TOOLS)/attribute_types_hb.xml \
55 $(MRW_HB_TOOLS)/attribute_types_oppowervm.xml \
Elizabeth Linerc0a38d72017-02-08 21:01:08 -060056 $(MRW_HB_TOOLS)/attribute_types_openpower.xml \
Robert Lippertaed5d2b2016-11-22 16:32:06 -080057 $(MRW_HB_TOOLS)/target_types_merged.xml \
58 $(MRW_HB_TOOLS)/target_types_hb.xml \
59 $(MRW_HB_TOOLS)/target_types_oppowervm.xml \
Elizabeth Linerc0a38d72017-02-08 21:01:08 -060060 $(MRW_HB_TOOLS)/target_types_openpower.xml \
Robert Lippertaed5d2b2016-11-22 16:32:06 -080061 $(MRW_SCRATCH)/$(BR2_ZAIUS_MRW_XML_FILENAME) > $(MRW_HB_TOOLS)/temporary_hb.hb.xml;
62
63 # creating the targeting binary
64 $(MRW_HB_TOOLS)/xmltohb.pl \
65 --hb-xml-file=$(MRW_HB_TOOLS)/temporary_hb.hb.xml \
66 --fapi-attributes-xml-file=$(MRW_HB_TOOLS)/fapiattrs.xml \
67 --src-output-dir=none \
68 --img-output-dir=$(MRW_HB_TOOLS)/ \
69 --vmm-consts-file=$(MRW_HB_TOOLS)/vmmconst.h --noshort-enums \
70 --bios-xml-file=$(ZAIUS_BIOS_XML_CONFIG_FILE) \
71 --bios-schema-file=$(BIOS_SCHEMA_FILE) \
72 --bios-output-file=$(BIOS_XML_METADATA_FILE)
73
74 # Transform BIOS XML into Petitboot specific BIOS XML via the schema
75 xsltproc -o \
76 $(PETITBOOT_BIOS_XML_METADATA_FILE) \
77 $(PETITBOOT_XSLT_FILE) \
78 $(BIOS_XML_METADATA_FILE)
79endef
80
81define ZAIUS_XML_INSTALL_IMAGES_CMDS
82 mv $(MRW_HB_TOOLS)/targeting.bin $(MRW_HB_TOOLS)/$(BR2_OPENPOWER_TARGETING_BIN_FILENAME)
83endef
84
85define ZAIUS_XML_INSTALL_TARGET_CMDS
86 # Install Petitboot specific BIOS XML into initramfs's usr/share/ dir
87 $(INSTALL) -D -m 0644 \
88 $(PETITBOOT_BIOS_XML_METADATA_FILE) \
89 $(PETITBOOT_BIOS_XML_METADATA_INITRAMFS_FILE)
90endef
91
92$(eval $(generic-package))