Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # openpower_targeting |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
| 7 | OPENPOWER_TARGETING_VERSION = 525d7b2eedab1708a53dfda94aad47128a62d40b |
| 8 | OPENPOWER_TARGETING_SITE = $(call github,open-power,hostboot-targeting,$(OPENPOWER_TARGETING_VERSION)) |
| 9 | OPENPOWER_TARGETING_LICENSE = Apache-2.0 |
| 10 | OPENPOWER_TARGETING_DEPENDENCIES = hostboot-install-images |
| 11 | |
| 12 | OPENPOWER_TARGETING_INSTALL_IMAGES = YES |
| 13 | OPENPOWER_TARGETING_INSTALL_TARGET = NO |
| 14 | |
| 15 | define OPENPOWER_TARGETING_INSTALL_IMAGES_CMDS |
| 16 | mkdir -p $(STAGING_DIR)/openpower_targeting/; |
| 17 | |
| 18 | $(STAGING_DIR)/hostboot_build_images/mergexml.sh $(@D)/$(BR2_OPENPOWER_TARGETING_SYSTEM_XML_FILENAME) $(STAGING_DIR)/hostboot_build_images/attribute_types.xml $(STAGING_DIR)/hostboot_build_images/attribute_types_hb.xml $(STAGING_DIR)/hostboot_build_images/target_types_merged.xml $(STAGING_DIR)/hostboot_build_images/target_types_hb.xml $(@D)/$(BR2_OPENPOWER_TARGETING_MRW_XML_FILENAME) > $(STAGING_DIR)/openpower_targeting/temporary_hb.hb.xml; |
| 19 | |
| 20 | $(STAGING_DIR)/hostboot_build_images/xmltohb.pl --hb-xml-file=$(STAGING_DIR)/openpower_targeting/temporary_hb.hb.xml --fapi-attributes-xml-file=$(STAGING_DIR)/hostboot_build_images/fapiattrs.xml --src-output-dir=none --img-output-dir=$(STAGING_DIR)/openpower_targeting/ --vmm-consts-file=$(STAGING_DIR)/hostboot_build_images/vmmconst.h --noshort-enums |
| 21 | |
| 22 | mv $(STAGING_DIR)/openpower_targeting/targeting.bin $(STAGING_DIR)/openpower_targeting/$(BR2_OPENPOWER_TARGETING_BIN_FILENAME) |
| 23 | endef |
| 24 | |
| 25 | $(eval $(generic-package)) |