Sachin Gupta | df0b6a0 | 2017-03-16 08:59:51 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # SBE |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
| 7 | SBE_VERSION ?= c9fea2e9662bdef548ea4742106b721386240ffe |
| 8 | SBE_SITE ?= $(call github,open-power,sbe,$(SBE_VERSION)) |
| 9 | |
| 10 | SBE_LICENSE = Apache-2.0 |
| 11 | SBE_DEPENDENCIES = host-ppe42-gcc |
| 12 | |
| 13 | SBE_INSTALL_IMAGES = YES |
| 14 | SBE_INSTALL_TARGET = NO |
| 15 | |
| 16 | define SBE_BUILD_CMDS |
| 17 | bash -c 'cd $(@D) && make LD_LIBRARY_PATH=$(HOST_DIR)/usr/lib CROSS_COMPILER_PATH=$(PPE42_GCC_BIN)' |
| 18 | endef |
| 19 | |
| 20 | define SBE_INSTALL_IMAGES_CMDS |
| 21 | $(INSTALL) -D $(@D)/images/p9_ipl_build $(HOST_DIR)/usr/bin/ |
| 22 | python $(@D)/src/build/sbeOpDistribute.py --sbe_binary_dir=$(STAGING_DIR)/sbe_binaries --img_dir=$(@D)/images |
| 23 | cp $(@D)/src/build/sbeOpDistribute.py $(STAGING_DIR)/sbe_binaries/ |
| 24 | endef |
| 25 | |
| 26 | $(eval $(generic-package)) |