Michael Neuling | 94f8ab1 | 2015-02-11 14:01:28 +1100 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # capp-ucode.mk |
| 4 | # |
| 5 | ################################################################################ |
Michael Neuling | 9c8a5ea | 2015-08-13 16:32:28 +1000 | [diff] [blame] | 6 | CAPP_UCODE_VERSION ?= 105cb8f69edb7e76c4d153bf2e5c9718811a3114 |
Michael Neuling | 94f8ab1 | 2015-02-11 14:01:28 +1100 | [diff] [blame] | 7 | CAPP_UCODE_SITE ?= $(call github,open-power,capp-ucode,$(CAPP_UCODE_VERSION)) |
| 8 | PETITBOOT_LICENSE = Apache-2.0 |
| 9 | |
| 10 | CAPP_UCODE_INSTALL_IMAGES = YES |
| 11 | |
| 12 | define CAPP_UCODE_BUILD_CMDS |
| 13 | cd $(@D) && ./build.sh |
| 14 | endef |
| 15 | |
| 16 | define CAPP_UCODE_INSTALL_IMAGES_CMDS |
| 17 | $(INSTALL) $(@D)/cappucode.bin $(BINARIES_DIR) |
| 18 | endef |
| 19 | |
| 20 | $(eval $(generic-package)) |