Matt Ploetz | e59bd1e | 2015-06-11 11:32:30 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # garrison_xml |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
hostboot | 72f6879 | 2016-07-29 00:07:06 -0500 | [diff] [blame^] | 7 | GARRISON_XML_VERSION ?= 4181f89bf6addf7e65346e7056228d56f4951400 |
Matt Ploetz | e59bd1e | 2015-06-11 11:32:30 -0500 | [diff] [blame] | 8 | GARRISON_XML_SITE ?= $(call github,open-power,garrison-xml,$(GARRISON_XML_VERSION)) |
| 9 | |
| 10 | GARRISON_XML_LICENSE = Apache-2.0 |
Jeremy Kerr | 28df94b | 2016-07-22 09:36:56 +0800 | [diff] [blame] | 11 | GARRISON_XML_DEPENDENCIES = hostboot openpower-mrw common-p8-xml |
Matt Ploetz | e59bd1e | 2015-06-11 11:32:30 -0500 | [diff] [blame] | 12 | |
| 13 | GARRISON_XML_INSTALL_IMAGES = YES |
| 14 | GARRISON_XML_INSTALL_TARGET = YES |
| 15 | |
| 16 | MRW_SCRATCH=$(STAGING_DIR)/openpower_mrw_scratch |
| 17 | MRW_HB_TOOLS=$(STAGING_DIR)/hostboot_build_images |
| 18 | |
| 19 | # Defines for BIOS metadata creation |
| 20 | BIOS_SCHEMA_FILE = $(MRW_HB_TOOLS)/bios.xsd |
| 21 | GARRISON_BIOS_XML_CONFIG_FILE = $(MRW_SCRATCH)/$(BR2_GARRISON_BIOS_XML_FILENAME) |
| 22 | BIOS_XML_METADATA_FILE = \ |
| 23 | $(MRW_HB_TOOLS)/$(BR2_OPENPOWER_CONFIG_NAME)_bios_metadata.xml |
| 24 | PETITBOOT_XSLT_FILE = $(MRW_HB_TOOLS)/bios_metadata_petitboot.xslt |
| 25 | PETITBOOT_BIOS_XML_METADATA_FILE = \ |
| 26 | $(MRW_HB_TOOLS)/$(BR2_OPENPOWER_CONFIG_NAME)_bios_metadata_petitboot.xml |
| 27 | PETITBOOT_BIOS_XML_METADATA_INITRAMFS_FILE = \ |
| 28 | $(TARGET_DIR)/usr/share/bios_metadata.xml |
| 29 | |
| 30 | define GARRISON_XML_BUILD_CMDS |
| 31 | # copy the garrison xml where the common lives |
| 32 | bash -c 'mkdir -p $(MRW_SCRATCH) && cp -r $(@D)/* $(MRW_SCRATCH)' |
| 33 | |
| 34 | # generate the system mrw xml |
| 35 | perl -I $(MRW_HB_TOOLS) \ |
| 36 | $(MRW_HB_TOOLS)/processMrw.pl -x $(MRW_SCRATCH)/garrison.xml |
| 37 | |
| 38 | # merge in any system specific attributes, hostboot attributes |
| 39 | $(MRW_HB_TOOLS)/mergexml.sh $(MRW_SCRATCH)/$(BR2_GARRISON_SYSTEM_XML_FILENAME) \ |
| 40 | $(MRW_HB_TOOLS)/attribute_types.xml \ |
| 41 | $(MRW_HB_TOOLS)/attribute_types_hb.xml \ |
| 42 | $(MRW_HB_TOOLS)/target_types_merged.xml \ |
| 43 | $(MRW_HB_TOOLS)/target_types_hb.xml \ |
| 44 | $(MRW_SCRATCH)/$(BR2_GARRISON_MRW_XML_FILENAME) > $(MRW_HB_TOOLS)/temporary_hb.hb.xml; |
| 45 | |
| 46 | # creating the targeting binary |
| 47 | $(MRW_HB_TOOLS)/xmltohb.pl \ |
| 48 | --hb-xml-file=$(MRW_HB_TOOLS)/temporary_hb.hb.xml \ |
| 49 | --fapi-attributes-xml-file=$(MRW_HB_TOOLS)/fapiattrs.xml \ |
| 50 | --src-output-dir=none \ |
| 51 | --img-output-dir=$(MRW_HB_TOOLS)/ \ |
| 52 | --vmm-consts-file=$(MRW_HB_TOOLS)/vmmconst.h --noshort-enums \ |
| 53 | --bios-xml-file=$(GARRISON_BIOS_XML_CONFIG_FILE) \ |
| 54 | --bios-schema-file=$(BIOS_SCHEMA_FILE) \ |
| 55 | --bios-output-file=$(BIOS_XML_METADATA_FILE) |
| 56 | |
| 57 | # Transform BIOS XML into Petitboot specific BIOS XML via the schema |
| 58 | xsltproc -o \ |
| 59 | $(PETITBOOT_BIOS_XML_METADATA_FILE) \ |
| 60 | $(PETITBOOT_XSLT_FILE) \ |
| 61 | $(BIOS_XML_METADATA_FILE) |
| 62 | endef |
| 63 | |
| 64 | define GARRISON_XML_INSTALL_IMAGES_CMDS |
| 65 | mv $(MRW_HB_TOOLS)/targeting.bin $(MRW_HB_TOOLS)/$(BR2_OPENPOWER_TARGETING_BIN_FILENAME) |
| 66 | endef |
| 67 | |
| 68 | define GARRISON_XML_INSTALL_TARGET_CMDS |
| 69 | # Install Petitboot specific BIOS XML into initramfs's usr/share/ dir |
| 70 | $(INSTALL) -D -m 0644 \ |
| 71 | $(PETITBOOT_BIOS_XML_METADATA_FILE) \ |
| 72 | $(PETITBOOT_BIOS_XML_METADATA_INITRAMFS_FILE) |
| 73 | endef |
| 74 | |
| 75 | $(eval $(generic-package)) |