blob: 37d77acdb216edfef3f82e3c288f784ed3385ee4 [file] [log] [blame]
Ramesh Iyyarebfe9d82020-03-23 21:58:20 -05001################################################################################
2#
3# ekb
4#
5################################################################################
6
7EKB_VERSION = $(call qstrip,$(BR2_EKB_VERSION))
8# TODO: WORKAROUND: Need to reenable next line and comment out the two lines
9# after that, when code is propagated to a public repo
10#EKB_SITE = $(call github,openbmc,ekb,$(EKB_VERSION))
Lakshminarayana R. Kammath75e43882020-05-15 08:10:12 -050011EKB_SITE = git@github.ibm.com:openbmc/pub-ekb.git
Ramesh Iyyarebfe9d82020-03-23 21:58:20 -050012EKB_SITE_METHOD = git
13
14EKB_INSTALL_STAGING = YES
15EKB_INSTALL_TARGET = NO
16
17EKB_STAGING_DIR = $(STAGING_DIR)/ekb/
18
19ifeq ($(BR2_OPENPOWER_POWER10),y)
20EKB_HWP_ATTRS_XML_FILES = chips/p10/procedures/xml/attribute_info/p10_clock_attributes.xml \
21 chips/p10/procedures/xml/attribute_info/p10_freq_attributes.xml \
22 chips/p10/procedures/xml/attribute_info/p10_ipl_attributes.xml \
23 chips/p10/procedures/xml/attribute_info/p10_nest_attributes.xml \
24 chips/p10/procedures/xml/attribute_info/p10_pervasive_attributes.xml \
25 chips/p10/procedures/xml/attribute_info/p10_runn_attributes.xml \
26 chips/p10/procedures/xml/attribute_info/p10_bars_attributes.xml \
27 hwpf/fapi2/xml/attribute_info/unit_attributes.xml \
28 hwpf/fapi2/xml/attribute_info/common_attributes.xml \
29 hwpf/fapi2/xml/attribute_info/chip_attributes.xml
30endif
31
32define EKB_INSTALL_STAGING_CMDS
33 # Creating ekb staging directory
34 mkdir -p $(EKB_STAGING_DIR)
35 # Copying all required hwps attributes xml file with respective directory structures
36 cd $(@D); cp --parents $(EKB_HWP_ATTRS_XML_FILES) $(EKB_STAGING_DIR)
37endef
38
39$(eval $(generic-package))