blob: b433e357f428e9baa5b36bc6ad5c5ef0b2e7eb50 [file] [log] [blame]
Nick Bofferdingf390b6f2019-10-08 11:55:42 -05001################################################################################
2#
3# SBE for P10
4#
5################################################################################
6
7SBE_P10_VERSION = $(call qstrip,$(BR2_SBE_P10_VERSION))
Ilya Smirnovd56cef72021-06-23 09:34:37 -05008SBE_P10_SITE ?= $(call github,open-power,sbe,$(SBE_P10_VERSION))
Nick Bofferdingf390b6f2019-10-08 11:55:42 -05009
10SBE_P10_LICENSE = Apache-2.0
11SBE_P10_DEPENDENCIES = host-ppe42-gcc hcode-p10
12# TODO WORKAROUND ... host-ppe42-gc not compiling
13# host-ppe42-gcc hcode-p10
14
15SBE_P10_INSTALL_IMAGES = YES
16SBE_P10_INSTALL_TARGET = NO
17
Klaus Heinrich Kiwid2551242020-07-16 16:59:04 -030018ifeq ($(BR2_PACKAGE_OPENPOWER_PNOR_P10),y)
19BINARY_SBE_FILENAME=$(BR2_HOSTBOOT_P10_BINARY_SBE_FILENAME)
20else
21BINARY_SBE_FILENAME=$(BR2_HOSTBOOT_BINARY_SBE_FILENAME)
22endif
23
Nick Bofferdingf390b6f2019-10-08 11:55:42 -050024define SBE_P10_BUILD_CMDS
25 SBE_COMMIT_ID=$(SBE_P10_VERSION) $(MAKE) -C $(@D) \
26 LD_LIBRARY_PATH=$(HOST_DIR)/usr/lib \
27 CROSS_COMPILER_PATH=$(PPE42_GCC_BIN) \
28 all
29endef
30
31define SBE_P10_INSTALL_IMAGES_CMDS
32 $(INSTALL) -D $(@D)/images/ipl_image_tool $(HOST_DIR)/usr/bin/
Klaus Heinrich Kiwid2551242020-07-16 16:59:04 -030033 python $(@D)/src/build/sbeOpDistribute.py --sbe_binary_dir=$(STAGING_DIR)/sbe_binaries --img_dir=$(@D)/images --sbe_binary_filename $(BINARY_SBE_FILENAME)
Nick Bofferdingf390b6f2019-10-08 11:55:42 -050034 cp $(@D)/src/build/sbeOpDistribute.py $(STAGING_DIR)/sbe_binaries/
hostboot717192c2020-02-20 06:05:18 -060035 cp $(@D)/src/build/sbeOpToolsRegister.py $(STAGING_DIR)/sbe_binaries/
Nick Bofferdingf390b6f2019-10-08 11:55:42 -050036endef
37
38$(eval $(generic-package))