Nick Bofferding | f390b6f | 2019-10-08 11:55:42 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # SBE for P10 |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
| 7 | SBE_P10_VERSION = $(call qstrip,$(BR2_SBE_P10_VERSION)) |
Ilya Smirnov | d56cef7 | 2021-06-23 09:34:37 -0500 | [diff] [blame] | 8 | SBE_P10_SITE ?= $(call github,open-power,sbe,$(SBE_P10_VERSION)) |
Nick Bofferding | f390b6f | 2019-10-08 11:55:42 -0500 | [diff] [blame] | 9 | |
| 10 | SBE_P10_LICENSE = Apache-2.0 |
| 11 | SBE_P10_DEPENDENCIES = host-ppe42-gcc hcode-p10 |
| 12 | # TODO WORKAROUND ... host-ppe42-gc not compiling |
| 13 | # host-ppe42-gcc hcode-p10 |
| 14 | |
| 15 | SBE_P10_INSTALL_IMAGES = YES |
| 16 | SBE_P10_INSTALL_TARGET = NO |
| 17 | |
Klaus Heinrich Kiwi | d255124 | 2020-07-16 16:59:04 -0300 | [diff] [blame] | 18 | ifeq ($(BR2_PACKAGE_OPENPOWER_PNOR_P10),y) |
| 19 | BINARY_SBE_FILENAME=$(BR2_HOSTBOOT_P10_BINARY_SBE_FILENAME) |
| 20 | else |
| 21 | BINARY_SBE_FILENAME=$(BR2_HOSTBOOT_BINARY_SBE_FILENAME) |
| 22 | endif |
| 23 | |
Nick Bofferding | f390b6f | 2019-10-08 11:55:42 -0500 | [diff] [blame] | 24 | define SBE_P10_BUILD_CMDS |
| 25 | SBE_COMMIT_ID=$(SBE_P10_VERSION) $(MAKE) -C $(@D) \ |
| 26 | LD_LIBRARY_PATH=$(HOST_DIR)/usr/lib \ |
| 27 | CROSS_COMPILER_PATH=$(PPE42_GCC_BIN) \ |
| 28 | all |
| 29 | endef |
| 30 | |
| 31 | define SBE_P10_INSTALL_IMAGES_CMDS |
| 32 | $(INSTALL) -D $(@D)/images/ipl_image_tool $(HOST_DIR)/usr/bin/ |
Klaus Heinrich Kiwi | d255124 | 2020-07-16 16:59:04 -0300 | [diff] [blame] | 33 | python $(@D)/src/build/sbeOpDistribute.py --sbe_binary_dir=$(STAGING_DIR)/sbe_binaries --img_dir=$(@D)/images --sbe_binary_filename $(BINARY_SBE_FILENAME) |
Nick Bofferding | f390b6f | 2019-10-08 11:55:42 -0500 | [diff] [blame] | 34 | cp $(@D)/src/build/sbeOpDistribute.py $(STAGING_DIR)/sbe_binaries/ |
hostboot | 717192c | 2020-02-20 06:05:18 -0600 | [diff] [blame] | 35 | cp $(@D)/src/build/sbeOpToolsRegister.py $(STAGING_DIR)/sbe_binaries/ |
Nick Bofferding | f390b6f | 2019-10-08 11:55:42 -0500 | [diff] [blame] | 36 | endef |
| 37 | |
| 38 | $(eval $(generic-package)) |