Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # ppe42-gcc |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
Robert Lippert | 3665f29 | 2016-12-15 10:38:42 -0800 | [diff] [blame] | 7 | PPE42_GCC_VERSION ?= d8a1bac8634033a3edd4e9a22455f97318718f43 |
Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 8 | PPE42_GCC_SITE ?= $(call github,open-power,ppe42-gcc,$(PPE42_GCC_VERSION)) |
| 9 | PPE42_GCC_LICENSE = GPLv3+ |
| 10 | |
| 11 | PPE42_GCC_DEPENDENCIES = ppe42-binutils |
| 12 | |
| 13 | PPE42_GCC_DIR = $(STAGING_DIR)/ppe42-binutils |
| 14 | PPE42_GCC_BIN = $(STAGING_DIR)/ppe42-binutils/linux |
| 15 | |
| 16 | define HOST_PPE42_GCC_BUILD_CMDS |
| 17 | cd $(@D) && \ |
| 18 | ./configure --prefix=$(PPE42_GCC_DIR) \ |
| 19 | --exec-prefix=$(PPE42_GCC_BIN) \ |
Doug Gilbert | 9a438d0 | 2016-10-31 13:43:07 -0500 | [diff] [blame] | 20 | --target=powerpc-eabi \ |
| 21 | --without-headers \ |
| 22 | --with-newlib \ |
| 23 | --with-gnu-as \ |
| 24 | --with-gnu-ld \ |
| 25 | --with-gmp=$(HOST_DIR)/usr \ |
| 26 | --with-mpfr=$(HOST_DIR)/usr \ |
| 27 | && \ |
Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 28 | make configure-host && \ |
| 29 | make all-gcc |
| 30 | endef |
| 31 | |
| 32 | define HOST_PPE42_GCC_INSTALL_CMDS |
| 33 | bash -c 'cd $(@D) && make install-gcc' |
| 34 | endef |
| 35 | |
| 36 | $(eval $(host-generic-package)) |