blob: 2ebdf5b855d223ebb73d53e5fc3225ac91b121e3 [file] [log] [blame]
Matt Ploetzc19ce762016-09-01 18:18:56 -05001################################################################################
2#
3# ppe42-gcc
4#
5################################################################################
6
Robert Lippert3665f292016-12-15 10:38:42 -08007PPE42_GCC_VERSION ?= d8a1bac8634033a3edd4e9a22455f97318718f43
Matt Ploetzc19ce762016-09-01 18:18:56 -05008PPE42_GCC_SITE ?= $(call github,open-power,ppe42-gcc,$(PPE42_GCC_VERSION))
9PPE42_GCC_LICENSE = GPLv3+
10
11PPE42_GCC_DEPENDENCIES = ppe42-binutils
12
13PPE42_GCC_DIR = $(STAGING_DIR)/ppe42-binutils
14PPE42_GCC_BIN = $(STAGING_DIR)/ppe42-binutils/linux
15
16define HOST_PPE42_GCC_BUILD_CMDS
17 cd $(@D) && \
18 ./configure --prefix=$(PPE42_GCC_DIR) \
19 --exec-prefix=$(PPE42_GCC_BIN) \
Doug Gilbert9a438d02016-10-31 13:43:07 -050020 --target=powerpc-eabi \
21 --without-headers \
22 --with-newlib \
23 --with-gnu-as \
24 --with-gnu-ld \
25 --with-gmp=$(HOST_DIR)/usr \
26 --with-mpfr=$(HOST_DIR)/usr \
27 && \
Matt Ploetzc19ce762016-09-01 18:18:56 -050028 make configure-host && \
29 make all-gcc
30endef
31
32define HOST_PPE42_GCC_INSTALL_CMDS
33 bash -c 'cd $(@D) && make install-gcc'
34endef
35
36$(eval $(host-generic-package))