blob: ec10e4f748bc2cacc377b3262e60ce8319060771 [file] [log] [blame]
Matt Ploetzc19ce762016-09-01 18:18:56 -05001################################################################################
2#
3# ppe42-gcc
4#
5################################################################################
6
Robert Lippert3665f292016-12-15 10:38:42 -08007PPE42_GCC_VERSION ?= d8a1bac8634033a3edd4e9a22455f97318718f43
Matt Ploetzc19ce762016-09-01 18:18:56 -05008PPE42_GCC_SITE ?= $(call github,open-power,ppe42-gcc,$(PPE42_GCC_VERSION))
9PPE42_GCC_LICENSE = GPLv3+
10
11PPE42_GCC_DEPENDENCIES = ppe42-binutils
William A. Kennington III0dda3f62017-02-10 17:11:48 -080012HOST_PPE42_GCC_DEPENDENCIES = host-ppe42-binutils
Matt Ploetzc19ce762016-09-01 18:18:56 -050013
14PPE42_GCC_DIR = $(STAGING_DIR)/ppe42-binutils
15PPE42_GCC_BIN = $(STAGING_DIR)/ppe42-binutils/linux
16
17define HOST_PPE42_GCC_BUILD_CMDS
18 cd $(@D) && \
19 ./configure --prefix=$(PPE42_GCC_DIR) \
20 --exec-prefix=$(PPE42_GCC_BIN) \
Doug Gilbert9a438d02016-10-31 13:43:07 -050021 --target=powerpc-eabi \
22 --without-headers \
23 --with-newlib \
24 --with-gnu-as \
25 --with-gnu-ld \
26 --with-gmp=$(HOST_DIR)/usr \
27 --with-mpfr=$(HOST_DIR)/usr \
28 && \
Stewart Smithaa697d02017-02-17 18:49:10 +110029 $(MAKE) configure-host && \
30 $(MAKE) CFLAGS=-Wno-error all-gcc
Matt Ploetzc19ce762016-09-01 18:18:56 -050031endef
32
33define HOST_PPE42_GCC_INSTALL_CMDS
34 bash -c 'cd $(@D) && make install-gcc'
35endef
36
37$(eval $(host-generic-package))