Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # ppe42-gcc |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
Robert Lippert | 3665f29 | 2016-12-15 10:38:42 -0800 | [diff] [blame] | 7 | PPE42_GCC_VERSION ?= d8a1bac8634033a3edd4e9a22455f97318718f43 |
Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 8 | PPE42_GCC_SITE ?= $(call github,open-power,ppe42-gcc,$(PPE42_GCC_VERSION)) |
| 9 | PPE42_GCC_LICENSE = GPLv3+ |
| 10 | |
| 11 | PPE42_GCC_DEPENDENCIES = ppe42-binutils |
William A. Kennington III | 0dda3f6 | 2017-02-10 17:11:48 -0800 | [diff] [blame] | 12 | HOST_PPE42_GCC_DEPENDENCIES = host-ppe42-binutils |
Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 13 | |
| 14 | PPE42_GCC_DIR = $(STAGING_DIR)/ppe42-binutils |
| 15 | PPE42_GCC_BIN = $(STAGING_DIR)/ppe42-binutils/linux |
| 16 | |
| 17 | define HOST_PPE42_GCC_BUILD_CMDS |
| 18 | cd $(@D) && \ |
| 19 | ./configure --prefix=$(PPE42_GCC_DIR) \ |
| 20 | --exec-prefix=$(PPE42_GCC_BIN) \ |
Doug Gilbert | 9a438d0 | 2016-10-31 13:43:07 -0500 | [diff] [blame] | 21 | --target=powerpc-eabi \ |
| 22 | --without-headers \ |
| 23 | --with-newlib \ |
| 24 | --with-gnu-as \ |
| 25 | --with-gnu-ld \ |
| 26 | --with-gmp=$(HOST_DIR)/usr \ |
| 27 | --with-mpfr=$(HOST_DIR)/usr \ |
| 28 | && \ |
Stewart Smith | aa697d0 | 2017-02-17 18:49:10 +1100 | [diff] [blame] | 29 | $(MAKE) configure-host && \ |
| 30 | $(MAKE) CFLAGS=-Wno-error all-gcc |
Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 31 | endef |
| 32 | |
| 33 | define HOST_PPE42_GCC_INSTALL_CMDS |
| 34 | bash -c 'cd $(@D) && make install-gcc' |
| 35 | endef |
| 36 | |
| 37 | $(eval $(host-generic-package)) |