Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # openpower_pnor |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
Brian Silver | 015b591 | 2014-08-07 15:50:15 -0500 | [diff] [blame] | 7 | # remove the quotes from the XML/Targeting package as |
| 8 | # make doesn't care for quotes in the dependencies. |
| 9 | XML_PACKAGE=$(subst $\",,$(BR2_OPENPOWER_XML_PACKAGE)) |
Brian Silver | 137a00a | 2014-11-11 12:09:53 -0600 | [diff] [blame] | 10 | |
Matt Ploetz | b4d85b1 | 2016-09-29 20:24:14 -0500 | [diff] [blame^] | 11 | OPENPOWER_PNOR_VERSION ?= fbd1f54baa655872aa21c5953a436f679386ffde |
Nick Bofferding | b82aaef | 2014-11-07 14:29:18 -0600 | [diff] [blame] | 12 | OPENPOWER_PNOR_SITE ?= $(call github,open-power,pnor,$(OPENPOWER_PNOR_VERSION)) |
Brian Silver | cb56555 | 2014-12-11 12:51:36 -0600 | [diff] [blame] | 13 | |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 14 | OPENPOWER_PNOR_LICENSE = Apache-2.0 |
Michael Neuling | 94f8ab1 | 2015-02-11 14:01:28 +1100 | [diff] [blame] | 15 | OPENPOWER_PNOR_DEPENDENCIES = hostboot hostboot-binaries $(XML_PACKAGE) skiboot host-openpower-ffs occ capp-ucode |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 16 | |
Stewart Smith | 898245e | 2016-03-30 15:26:23 +1100 | [diff] [blame] | 17 | ifeq ($(BR2_PACKAGE_SKIBOOT_EMBED_PAYLOAD),n) |
Joel Stanley | 2aff5ba | 2015-02-01 14:49:18 +1030 | [diff] [blame] | 18 | |
| 19 | ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y) |
Stewart Smith | 906bdba | 2015-08-26 16:05:20 +1000 | [diff] [blame] | 20 | OPENPOWER_PNOR_DEPENDENCIES += linux-rebuild-with-initramfs |
Joel Stanley | 2aff5ba | 2015-02-01 14:49:18 +1030 | [diff] [blame] | 21 | else |
| 22 | OPENPOWER_PNOR_DEPENDENCIES += linux |
| 23 | endif |
| 24 | |
| 25 | endif |
| 26 | |
Elizabeth Liner | fbd6c45 | 2016-03-31 10:38:17 -0500 | [diff] [blame] | 27 | ifeq ($(BR2_OPENPOWER_PNOR_XZ_ENABLED),y) |
Jeremy Kerr | c780084 | 2016-07-22 14:01:17 +0800 | [diff] [blame] | 28 | OPENPOWER_PNOR_DEPENDENCIES += host-xz |
Elizabeth Liner | fbd6c45 | 2016-03-31 10:38:17 -0500 | [diff] [blame] | 29 | endif |
| 30 | |
Matt Ploetz | b4d85b1 | 2016-09-29 20:24:14 -0500 | [diff] [blame^] | 31 | ifeq ($(BR2_OPENPOWER_POWER9),y) |
| 32 | OPENPOWER_RELEASE=p9 |
| 33 | else |
| 34 | OPENPOWER_RELEASE=p8 |
| 35 | endif |
| 36 | |
Elizabeth Liner | fbd6c45 | 2016-03-31 10:38:17 -0500 | [diff] [blame] | 37 | |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 38 | OPENPOWER_PNOR_INSTALL_IMAGES = YES |
| 39 | OPENPOWER_PNOR_INSTALL_TARGET = NO |
| 40 | |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 41 | HOSTBOOT_IMAGE_DIR=$(STAGING_DIR)/hostboot_build_images/ |
| 42 | HOSTBOOT_BINARY_DIR = $(STAGING_DIR)/hostboot_binaries/ |
| 43 | OPENPOWER_PNOR_SCRATCH_DIR = $(STAGING_DIR)/openpower_pnor_scratch/ |
Stephen Cprek | e7254c7 | 2015-02-19 14:33:38 -0600 | [diff] [blame] | 44 | OPENPOWER_VERSION_DIR = $(STAGING_DIR)/openpower_version |
| 45 | |
| 46 | # Subpackages we want to include in the version info (do not include openpower-pnor) |
Sam Mendoza-Jonas | 33f3044 | 2016-03-01 16:38:56 +1100 | [diff] [blame] | 47 | OPENPOWER_VERSIONED_SUBPACKAGES = skiboot hostboot linux petitboot $(XML_PACKAGE) occ hostboot-binaries capp-ucode |
Stephen Cprek | e7254c7 | 2015-02-19 14:33:38 -0600 | [diff] [blame] | 48 | OPENPOWER_PNOR = openpower-pnor |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 49 | |
| 50 | define OPENPOWER_PNOR_INSTALL_IMAGES_CMDS |
| 51 | mkdir -p $(OPENPOWER_PNOR_SCRATCH_DIR) |
Brian Silver | 015b591 | 2014-08-07 15:50:15 -0500 | [diff] [blame] | 52 | |
Brian Silver | 137a00a | 2014-11-11 12:09:53 -0600 | [diff] [blame] | 53 | $(TARGET_MAKE_ENV) $(@D)/update_image.pl \ |
Matt Ploetz | b4d85b1 | 2016-09-29 20:24:14 -0500 | [diff] [blame^] | 54 | -release $(OPENPOWER_RELEASE) \ |
Brian Silver | 015b591 | 2014-08-07 15:50:15 -0500 | [diff] [blame] | 55 | -op_target_dir $(HOSTBOOT_IMAGE_DIR) \ |
Brian Silver | 131189b | 2014-11-10 08:11:22 -0600 | [diff] [blame] | 56 | -hb_image_dir $(HOSTBOOT_IMAGE_DIR) \ |
| 57 | -scratch_dir $(OPENPOWER_PNOR_SCRATCH_DIR) \ |
| 58 | -hb_binary_dir $(HOSTBOOT_BINARY_DIR) \ |
| 59 | -targeting_binary_filename $(BR2_OPENPOWER_TARGETING_ECC_FILENAME) \ |
Brian Silver | 137a00a | 2014-11-11 12:09:53 -0600 | [diff] [blame] | 60 | -targeting_binary_source $(BR2_OPENPOWER_TARGETING_BIN_FILENAME) \ |
| 61 | -sbe_binary_filename $(BR2_HOSTBOOT_BINARY_SBE_FILENAME) \ |
Brian Silver | cb56555 | 2014-12-11 12:51:36 -0600 | [diff] [blame] | 62 | -sbec_binary_filename $(BR2_HOSTBOOT_BINARY_SBEC_FILENAME) \ |
Matt Ploetz | af3f64e | 2015-05-14 14:49:55 -0500 | [diff] [blame] | 63 | -wink_binary_filename $(BR2_HOSTBOOT_BINARY_WINK_FILENAME) \ |
Michael Neuling | 94f8ab1 | 2015-02-11 14:01:28 +1100 | [diff] [blame] | 64 | -occ_binary_filename $(OCC_STAGING_DIR)/$(BR2_OCC_BIN_FILENAME) \ |
Stephen Cprek | e7254c7 | 2015-02-19 14:33:38 -0600 | [diff] [blame] | 65 | -capp_binary_filename $(BINARIES_DIR)/$(BR2_CAPP_UCODE_BIN_FILENAME) \ |
Matt Ploetz | 02aa69d | 2016-09-12 18:17:15 -0500 | [diff] [blame] | 66 | -ima_catalog_filename $(BR2_IMA_CATALOG_FILENAME) \ |
Elizabeth Liner | fbd6c45 | 2016-03-31 10:38:17 -0500 | [diff] [blame] | 67 | -openpower_version_filename $(OPENPOWER_PNOR_VERSION_FILE) \ |
| 68 | -payload $(BINARIES_DIR)/$(BR2_SKIBOOT_LID_NAME) \ |
Elizabeth Liner | ff5fb5f | 2016-08-19 16:16:33 -0500 | [diff] [blame] | 69 | $(if ($(BR2_OPENPOWER_PNOR_XZ_ENABLED),y),-xz_compression) |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 70 | |
| 71 | mkdir -p $(STAGING_DIR)/pnor/ |
Brian Silver | 131189b | 2014-11-10 08:11:22 -0600 | [diff] [blame] | 72 | $(TARGET_MAKE_ENV) $(@D)/create_pnor_image.pl \ |
Matt Ploetz | b4d85b1 | 2016-09-29 20:24:14 -0500 | [diff] [blame^] | 73 | -release $(OPENPOWER_RELEASE) \ |
| 74 | -xml_layout_file $(@D)/"$(OPENPOWER_RELEASE)"Layouts/$(BR2_OPENPOWER_PNOR_XML_LAYOUT_FILENAME) \ |
Brian Silver | 131189b | 2014-11-10 08:11:22 -0600 | [diff] [blame] | 75 | -pnor_filename $(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_FILENAME) \ |
| 76 | -hb_image_dir $(HOSTBOOT_IMAGE_DIR) \ |
| 77 | -scratch_dir $(OPENPOWER_PNOR_SCRATCH_DIR) \ |
| 78 | -outdir $(STAGING_DIR)/pnor/ \ |
Elizabeth Liner | fbd6c45 | 2016-03-31 10:38:17 -0500 | [diff] [blame] | 79 | -payload $(BINARIES_DIR)/$(BR2_SKIBOOT_LID_XZ_NAME) \ |
Joel Stanley | 2aff5ba | 2015-02-01 14:49:18 +1030 | [diff] [blame] | 80 | -bootkernel $(BINARIES_DIR)/$(LINUX_IMAGE_NAME) \ |
Brian Silver | 131189b | 2014-11-10 08:11:22 -0600 | [diff] [blame] | 81 | -sbe_binary_filename $(BR2_HOSTBOOT_BINARY_SBE_FILENAME) \ |
| 82 | -sbec_binary_filename $(BR2_HOSTBOOT_BINARY_SBEC_FILENAME) \ |
Matt Ploetz | af3f64e | 2015-05-14 14:49:55 -0500 | [diff] [blame] | 83 | -wink_binary_filename $(BR2_HOSTBOOT_BINARY_WINK_FILENAME) \ |
Brian Silver | cb56555 | 2014-12-11 12:51:36 -0600 | [diff] [blame] | 84 | -occ_binary_filename $(OCC_STAGING_DIR)/$(BR2_OCC_BIN_FILENAME) \ |
Matt Ploetz | 02aa69d | 2016-09-12 18:17:15 -0500 | [diff] [blame] | 85 | -ima_catalog_filename $(BR2_IMA_CATALOG_ECC_FILENAME) \ |
Stephen Cprek | e7254c7 | 2015-02-19 14:33:38 -0600 | [diff] [blame] | 86 | -targeting_binary_filename $(BR2_OPENPOWER_TARGETING_ECC_FILENAME) \ |
Elizabeth Liner | 0ce28ef | 2016-07-11 09:34:09 -0500 | [diff] [blame] | 87 | -openpower_version_filename $(OPENPOWER_PNOR_VERSION_FILE) |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 88 | |
Brian Silver | 131189b | 2014-11-10 08:11:22 -0600 | [diff] [blame] | 89 | $(INSTALL) $(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_FILENAME) $(BINARIES_DIR) |
Brian Horton | 06c2a88 | 2015-04-09 13:32:55 -0500 | [diff] [blame] | 90 | |
| 91 | # if this config has an UPDATE_FILENAME defined, create a 32M (1/2 size) |
| 92 | # image that only updates the non-golden side |
| 93 | if [ "$(BR2_OPENPOWER_PNOR_UPDATE_FILENAME)" != "" ]; then \ |
| 94 | dd if=$(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_FILENAME) of=$(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_UPDATE_FILENAME) bs=32M count=1; \ |
| 95 | $(INSTALL) $(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_UPDATE_FILENAME) $(BINARIES_DIR); \ |
| 96 | fi |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 97 | endef |
| 98 | |
| 99 | $(eval $(generic-package)) |
Stephen Cprek | e7254c7 | 2015-02-19 14:33:38 -0600 | [diff] [blame] | 100 | # Generate openPOWER pnor version string by combining subpackage version string files |
| 101 | $(eval $(call OPENPOWER_VERSION,$(OPENPOWER_PNOR))) |