Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # openpower_pnor |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
Brian Silver | 015b591 | 2014-08-07 15:50:15 -0500 | [diff] [blame] | 7 | # remove the quotes from the XML/Targeting package as |
| 8 | # make doesn't care for quotes in the dependencies. |
| 9 | XML_PACKAGE=$(subst $\",,$(BR2_OPENPOWER_XML_PACKAGE)) |
Brian Silver | 137a00a | 2014-11-11 12:09:53 -0600 | [diff] [blame] | 10 | |
Jay Azurin | e48917b | 2015-08-26 20:49:00 -0500 | [diff] [blame] | 11 | OPENPOWER_PNOR_VERSION ?= 40e407735b317d0174645b7543e0a72019709ce2 |
Nick Bofferding | b82aaef | 2014-11-07 14:29:18 -0600 | [diff] [blame] | 12 | OPENPOWER_PNOR_SITE ?= $(call github,open-power,pnor,$(OPENPOWER_PNOR_VERSION)) |
Brian Silver | cb56555 | 2014-12-11 12:51:36 -0600 | [diff] [blame] | 13 | |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 14 | OPENPOWER_PNOR_LICENSE = Apache-2.0 |
Michael Neuling | 94f8ab1 | 2015-02-11 14:01:28 +1100 | [diff] [blame] | 15 | OPENPOWER_PNOR_DEPENDENCIES = hostboot hostboot-binaries $(XML_PACKAGE) skiboot host-openpower-ffs occ capp-ucode |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 16 | |
Joel Stanley | 2aff5ba | 2015-02-01 14:49:18 +1030 | [diff] [blame] | 17 | ifeq ($(BR2_TARGET_SKIBOOT_EMBED_PAYLOAD),n) |
| 18 | |
| 19 | ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y) |
Stewart Smith | 906bdba | 2015-08-26 16:05:20 +1000 | [diff] [blame] | 20 | OPENPOWER_PNOR_DEPENDENCIES += linux-rebuild-with-initramfs |
Joel Stanley | 2aff5ba | 2015-02-01 14:49:18 +1030 | [diff] [blame] | 21 | else |
| 22 | OPENPOWER_PNOR_DEPENDENCIES += linux |
| 23 | endif |
| 24 | |
| 25 | endif |
| 26 | |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 27 | OPENPOWER_PNOR_INSTALL_IMAGES = YES |
| 28 | OPENPOWER_PNOR_INSTALL_TARGET = NO |
| 29 | |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 30 | HOSTBOOT_IMAGE_DIR=$(STAGING_DIR)/hostboot_build_images/ |
| 31 | HOSTBOOT_BINARY_DIR = $(STAGING_DIR)/hostboot_binaries/ |
| 32 | OPENPOWER_PNOR_SCRATCH_DIR = $(STAGING_DIR)/openpower_pnor_scratch/ |
Stephen Cprek | e7254c7 | 2015-02-19 14:33:38 -0600 | [diff] [blame] | 33 | OPENPOWER_VERSION_DIR = $(STAGING_DIR)/openpower_version |
| 34 | |
| 35 | # Subpackages we want to include in the version info (do not include openpower-pnor) |
| 36 | OPENPOWER_VERSIONED_SUBPACKAGES = hostboot occ skiboot hostboot-binaries $(XML_PACKAGE) capp-ucode |
| 37 | OPENPOWER_PNOR = openpower-pnor |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 38 | |
| 39 | define OPENPOWER_PNOR_INSTALL_IMAGES_CMDS |
| 40 | mkdir -p $(OPENPOWER_PNOR_SCRATCH_DIR) |
Brian Silver | 015b591 | 2014-08-07 15:50:15 -0500 | [diff] [blame] | 41 | |
Brian Silver | 137a00a | 2014-11-11 12:09:53 -0600 | [diff] [blame] | 42 | $(TARGET_MAKE_ENV) $(@D)/update_image.pl \ |
Brian Silver | 015b591 | 2014-08-07 15:50:15 -0500 | [diff] [blame] | 43 | -op_target_dir $(HOSTBOOT_IMAGE_DIR) \ |
Brian Silver | 131189b | 2014-11-10 08:11:22 -0600 | [diff] [blame] | 44 | -hb_image_dir $(HOSTBOOT_IMAGE_DIR) \ |
| 45 | -scratch_dir $(OPENPOWER_PNOR_SCRATCH_DIR) \ |
| 46 | -hb_binary_dir $(HOSTBOOT_BINARY_DIR) \ |
| 47 | -targeting_binary_filename $(BR2_OPENPOWER_TARGETING_ECC_FILENAME) \ |
Brian Silver | 137a00a | 2014-11-11 12:09:53 -0600 | [diff] [blame] | 48 | -targeting_binary_source $(BR2_OPENPOWER_TARGETING_BIN_FILENAME) \ |
| 49 | -sbe_binary_filename $(BR2_HOSTBOOT_BINARY_SBE_FILENAME) \ |
Brian Silver | cb56555 | 2014-12-11 12:51:36 -0600 | [diff] [blame] | 50 | -sbec_binary_filename $(BR2_HOSTBOOT_BINARY_SBEC_FILENAME) \ |
Matt Ploetz | af3f64e | 2015-05-14 14:49:55 -0500 | [diff] [blame] | 51 | -wink_binary_filename $(BR2_HOSTBOOT_BINARY_WINK_FILENAME) \ |
Michael Neuling | 94f8ab1 | 2015-02-11 14:01:28 +1100 | [diff] [blame] | 52 | -occ_binary_filename $(OCC_STAGING_DIR)/$(BR2_OCC_BIN_FILENAME) \ |
Stephen Cprek | e7254c7 | 2015-02-19 14:33:38 -0600 | [diff] [blame] | 53 | -capp_binary_filename $(BINARIES_DIR)/$(BR2_CAPP_UCODE_BIN_FILENAME) \ |
| 54 | -openpower_version_filename $(OPENPOWER_PNOR_VERSION_FILE) |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 55 | |
| 56 | mkdir -p $(STAGING_DIR)/pnor/ |
Brian Silver | 131189b | 2014-11-10 08:11:22 -0600 | [diff] [blame] | 57 | $(TARGET_MAKE_ENV) $(@D)/create_pnor_image.pl \ |
| 58 | -xml_layout_file $(@D)/$(BR2_OPENPOWER_PNOR_XML_LAYOUT_FILENAME) \ |
| 59 | -pnor_filename $(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_FILENAME) \ |
| 60 | -hb_image_dir $(HOSTBOOT_IMAGE_DIR) \ |
| 61 | -scratch_dir $(OPENPOWER_PNOR_SCRATCH_DIR) \ |
| 62 | -outdir $(STAGING_DIR)/pnor/ \ |
| 63 | -payload $(BINARIES_DIR)/$(BR2_SKIBOOT_LID_NAME) \ |
Joel Stanley | 2aff5ba | 2015-02-01 14:49:18 +1030 | [diff] [blame] | 64 | -bootkernel $(BINARIES_DIR)/$(LINUX_IMAGE_NAME) \ |
Brian Silver | 131189b | 2014-11-10 08:11:22 -0600 | [diff] [blame] | 65 | -sbe_binary_filename $(BR2_HOSTBOOT_BINARY_SBE_FILENAME) \ |
| 66 | -sbec_binary_filename $(BR2_HOSTBOOT_BINARY_SBEC_FILENAME) \ |
Matt Ploetz | af3f64e | 2015-05-14 14:49:55 -0500 | [diff] [blame] | 67 | -wink_binary_filename $(BR2_HOSTBOOT_BINARY_WINK_FILENAME) \ |
Brian Silver | cb56555 | 2014-12-11 12:51:36 -0600 | [diff] [blame] | 68 | -occ_binary_filename $(OCC_STAGING_DIR)/$(BR2_OCC_BIN_FILENAME) \ |
Stephen Cprek | e7254c7 | 2015-02-19 14:33:38 -0600 | [diff] [blame] | 69 | -targeting_binary_filename $(BR2_OPENPOWER_TARGETING_ECC_FILENAME) \ |
| 70 | -openpower_version_filename $(OPENPOWER_PNOR_VERSION_FILE) |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 71 | |
Brian Silver | 131189b | 2014-11-10 08:11:22 -0600 | [diff] [blame] | 72 | $(INSTALL) $(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_FILENAME) $(BINARIES_DIR) |
Brian Horton | 06c2a88 | 2015-04-09 13:32:55 -0500 | [diff] [blame] | 73 | |
| 74 | # if this config has an UPDATE_FILENAME defined, create a 32M (1/2 size) |
| 75 | # image that only updates the non-golden side |
| 76 | if [ "$(BR2_OPENPOWER_PNOR_UPDATE_FILENAME)" != "" ]; then \ |
| 77 | dd if=$(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_FILENAME) of=$(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_UPDATE_FILENAME) bs=32M count=1; \ |
| 78 | $(INSTALL) $(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_UPDATE_FILENAME) $(BINARIES_DIR); \ |
| 79 | fi |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 80 | endef |
| 81 | |
| 82 | $(eval $(generic-package)) |
Stephen Cprek | e7254c7 | 2015-02-19 14:33:38 -0600 | [diff] [blame] | 83 | # Generate openPOWER pnor version string by combining subpackage version string files |
| 84 | $(eval $(call OPENPOWER_VERSION,$(OPENPOWER_PNOR))) |