blob: 362dfc5d448e6b8e41d50845dc1eeb60c5a6427d [file] [log] [blame]
Bill Hoffa5f93f1d2014-06-26 21:02:48 -05001################################################################################
2#
3# openpower_pnor
4#
5################################################################################
6
Brian Silver1b205ee2014-07-11 14:05:57 -05007OPENPOWER_PNOR_VERSION = cbbad9d46f77de6e9e845561ed6bea6d55cb862c
Bill Hoffa5f93f1d2014-06-26 21:02:48 -05008OPENPOWER_PNOR_SITE = $(call github,open-power,pnor,$(OPENPOWER_PNOR_VERSION))
9OPENPOWER_PNOR_LICENSE = Apache-2.0
Brian Silver1b205ee2014-07-11 14:05:57 -050010OPENPOWER_PNOR_DEPENDENCIES = hostboot hostboot-binaries openpower-targeting skiboot host-openpower-ffs
Bill Hoffa5f93f1d2014-06-26 21:02:48 -050011
12OPENPOWER_PNOR_INSTALL_IMAGES = YES
13OPENPOWER_PNOR_INSTALL_TARGET = NO
14
15#OPENPOWER_PNOR_FILENAME = palmetto.pnor
16#OPENPOWER_PNOR_TARGETING_FILE = $(STAGING_DIR)/openpower_targeting/PALMETTO_HB_targeting.bin
17
18
19#ECC_TOOL_DIR ???
20OPENPOWER_TARGETING_DIR=$(STAGING_DIR)/openpower_targeting/
21HOSTBOOT_IMAGE_DIR=$(STAGING_DIR)/hostboot_build_images/
22HOSTBOOT_BINARY_DIR = $(STAGING_DIR)/hostboot_binaries/
23OPENPOWER_PNOR_SCRATCH_DIR = $(STAGING_DIR)/openpower_pnor_scratch/
24
25define OPENPOWER_PNOR_INSTALL_IMAGES_CMDS
26 mkdir -p $(OPENPOWER_PNOR_SCRATCH_DIR)
Brian Silverc5261532014-07-14 11:06:41 -050027 $(TARGET_MAKE_ENV) $(@D)/update_image_$(BR2_OPENPOWER_CONFIG_NAME).pl -op_target_dir $(STAGING_DIR)/openpower_targeting/ -hb_image_dir $(HOSTBOOT_IMAGE_DIR) -scratch_dir $(OPENPOWER_PNOR_SCRATCH_DIR) -hb_binary_dir $(HOSTBOOT_BINARY_DIR) -targeting_binary_filename $(BR2_OPENPOWER_TARGETING_ECC_FILENAME) -targeting_binary_source $(BR2_OPENPOWER_TARGETING_BIN_FILENAME)
Bill Hoffa5f93f1d2014-06-26 21:02:48 -050028
29 mkdir -p $(STAGING_DIR)/pnor/
Brian Silverc5261532014-07-14 11:06:41 -050030 $(TARGET_MAKE_ENV) $(@D)/create_pnor_image.pl -xml_layout_file $(@D)/$(BR2_OPENPOWER_PNOR_XML_LAYOUT_FILENAME) -pnor_filename $(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_FILENAME) -hb_image_dir $(HOSTBOOT_IMAGE_DIR) -scratch_dir $(OPENPOWER_PNOR_SCRATCH_DIR) -outdir $(STAGING_DIR)/pnor/ -payload $(BINARIES_DIR)/$(BR2_SKIBOOT_LID_NAME) -sbe_binary_filename $(BR2_HOSTBOOT_BINARY_SBE_FILENAME) -sbec_binary_filename $(BR2_HOSTBOOT_BINARY_SBEC_FILENAME) -targeting_binary_filename $(BR2_OPENPOWER_TARGETING_ECC_FILENAME)
Bill Hoffa5f93f1d2014-06-26 21:02:48 -050031
32 $(INSTALL) $(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_FILENAME) $(BINARIES_DIR)
33endef
34
35$(eval $(generic-package))