Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # openpower_pnor |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
Brian Silver | 1b205ee | 2014-07-11 14:05:57 -0500 | [diff] [blame] | 7 | OPENPOWER_PNOR_VERSION = cbbad9d46f77de6e9e845561ed6bea6d55cb862c |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 8 | OPENPOWER_PNOR_SITE = $(call github,open-power,pnor,$(OPENPOWER_PNOR_VERSION)) |
| 9 | OPENPOWER_PNOR_LICENSE = Apache-2.0 |
Brian Silver | 1b205ee | 2014-07-11 14:05:57 -0500 | [diff] [blame] | 10 | OPENPOWER_PNOR_DEPENDENCIES = hostboot hostboot-binaries openpower-targeting skiboot host-openpower-ffs |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 11 | |
| 12 | OPENPOWER_PNOR_INSTALL_IMAGES = YES |
| 13 | OPENPOWER_PNOR_INSTALL_TARGET = NO |
| 14 | |
| 15 | #OPENPOWER_PNOR_FILENAME = palmetto.pnor |
| 16 | #OPENPOWER_PNOR_TARGETING_FILE = $(STAGING_DIR)/openpower_targeting/PALMETTO_HB_targeting.bin |
| 17 | |
| 18 | |
| 19 | #ECC_TOOL_DIR ??? |
| 20 | OPENPOWER_TARGETING_DIR=$(STAGING_DIR)/openpower_targeting/ |
| 21 | HOSTBOOT_IMAGE_DIR=$(STAGING_DIR)/hostboot_build_images/ |
| 22 | HOSTBOOT_BINARY_DIR = $(STAGING_DIR)/hostboot_binaries/ |
| 23 | OPENPOWER_PNOR_SCRATCH_DIR = $(STAGING_DIR)/openpower_pnor_scratch/ |
| 24 | |
| 25 | define OPENPOWER_PNOR_INSTALL_IMAGES_CMDS |
| 26 | mkdir -p $(OPENPOWER_PNOR_SCRATCH_DIR) |
Brian Silver | c526153 | 2014-07-14 11:06:41 -0500 | [diff] [blame^] | 27 | $(TARGET_MAKE_ENV) $(@D)/update_image_$(BR2_OPENPOWER_CONFIG_NAME).pl -op_target_dir $(STAGING_DIR)/openpower_targeting/ -hb_image_dir $(HOSTBOOT_IMAGE_DIR) -scratch_dir $(OPENPOWER_PNOR_SCRATCH_DIR) -hb_binary_dir $(HOSTBOOT_BINARY_DIR) -targeting_binary_filename $(BR2_OPENPOWER_TARGETING_ECC_FILENAME) -targeting_binary_source $(BR2_OPENPOWER_TARGETING_BIN_FILENAME) |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 28 | |
| 29 | mkdir -p $(STAGING_DIR)/pnor/ |
Brian Silver | c526153 | 2014-07-14 11:06:41 -0500 | [diff] [blame^] | 30 | $(TARGET_MAKE_ENV) $(@D)/create_pnor_image.pl -xml_layout_file $(@D)/$(BR2_OPENPOWER_PNOR_XML_LAYOUT_FILENAME) -pnor_filename $(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_FILENAME) -hb_image_dir $(HOSTBOOT_IMAGE_DIR) -scratch_dir $(OPENPOWER_PNOR_SCRATCH_DIR) -outdir $(STAGING_DIR)/pnor/ -payload $(BINARIES_DIR)/$(BR2_SKIBOOT_LID_NAME) -sbe_binary_filename $(BR2_HOSTBOOT_BINARY_SBE_FILENAME) -sbec_binary_filename $(BR2_HOSTBOOT_BINARY_SBEC_FILENAME) -targeting_binary_filename $(BR2_OPENPOWER_TARGETING_ECC_FILENAME) |
Bill Hoffa | 5f93f1d | 2014-06-26 21:02:48 -0500 | [diff] [blame] | 31 | |
| 32 | $(INSTALL) $(STAGING_DIR)/pnor/$(BR2_OPENPOWER_PNOR_FILENAME) $(BINARIES_DIR) |
| 33 | endef |
| 34 | |
| 35 | $(eval $(generic-package)) |