blob: a9bf202e7ca4a773923f5a46522ace55c921d790 [file] [log] [blame]
Ramesh Iyyarebfe9d82020-03-23 21:58:20 -05001################################################################################
2#
3# ekb
4#
5################################################################################
6
7EKB_VERSION = $(call qstrip,$(BR2_EKB_VERSION))
Ilya Smirnovd56cef72021-06-23 09:34:37 -05008EKB_SITE = $(call github,open-power,pub-ekb,$(EKB_VERSION))
Ramesh Iyyarebfe9d82020-03-23 21:58:20 -05009
10EKB_INSTALL_STAGING = YES
11EKB_INSTALL_TARGET = NO
12
13EKB_STAGING_DIR = $(STAGING_DIR)/ekb/
14
15ifeq ($(BR2_OPENPOWER_POWER10),y)
16EKB_HWP_ATTRS_XML_FILES = chips/p10/procedures/xml/attribute_info/p10_clock_attributes.xml \
17 chips/p10/procedures/xml/attribute_info/p10_freq_attributes.xml \
18 chips/p10/procedures/xml/attribute_info/p10_ipl_attributes.xml \
19 chips/p10/procedures/xml/attribute_info/p10_nest_attributes.xml \
20 chips/p10/procedures/xml/attribute_info/p10_pervasive_attributes.xml \
21 chips/p10/procedures/xml/attribute_info/p10_runn_attributes.xml \
22 chips/p10/procedures/xml/attribute_info/p10_bars_attributes.xml \
23 hwpf/fapi2/xml/attribute_info/unit_attributes.xml \
24 hwpf/fapi2/xml/attribute_info/common_attributes.xml \
25 hwpf/fapi2/xml/attribute_info/chip_attributes.xml
26endif
27
28define EKB_INSTALL_STAGING_CMDS
29 # Creating ekb staging directory
30 mkdir -p $(EKB_STAGING_DIR)
31 # Copying all required hwps attributes xml file with respective directory structures
32 cd $(@D); cp --parents $(EKB_HWP_ATTRS_XML_FILES) $(EKB_STAGING_DIR)
33endef
34
35$(eval $(generic-package))