blob: 5b334221432b46ef1dc5a331bb45485bd7a7e216 [file] [log] [blame]
Brian Silvercb565552014-12-11 12:51:36 -06001################################################################################
2#
3# p8-pore-binutils
4#
5################################################################################
6
Joel Stanley9e02d1b2015-02-02 13:57:34 +10307P8_PORE_BINUTILS_VERSION ?= dcf4f87c0d9e8c8092ace0eb696189ee1056da30
Patrick Williams01f14c82014-12-11 19:03:42 -06008P8_PORE_BINUTILS_SITE ?= $(call github,open-power,p8-pore-binutils,$(P8_PORE_BINUTILS_VERSION))
9P8_PORE_BINUTILS_LICENSE = GPLv3+
Brian Silvercb565552014-12-11 12:51:36 -060010
Patrick Williams01f14c82014-12-11 19:03:42 -060011HOST_P8_PORE_BINUTILS_DEPENDENCIES = host-binutils
Brian Silvercb565552014-12-11 12:51:36 -060012
13P8_PORE_BINUTILS_DIR = $(STAGING_DIR)/p8-pore-binutils
14P8_PORE_BINUTILS_BIN = $(STAGING_DIR)/p8-pore-binutils/linux
15
Patrick Williams01f14c82014-12-11 19:03:42 -060016define HOST_P8_PORE_BINUTILS_BUILD_CMDS
Brian Silvercb565552014-12-11 12:51:36 -060017 cd $(@D) && \
18 ./configure --prefix=$(P8_PORE_BINUTILS_DIR) \
19 --exec-prefix=$(P8_PORE_BINUTILS_BIN) \
Patrick Williams01f14c82014-12-11 19:03:42 -060020 --target=pore-elf64 && \
Brian Silvercb565552014-12-11 12:51:36 -060021 make configure-host && \
22 make LDFLAGS=-all-static
23endef
24
Patrick Williams01f14c82014-12-11 19:03:42 -060025define HOST_P8_PORE_BINUTILS_INSTALL_CMDS
Brian Silvercb565552014-12-11 12:51:36 -060026 bash -c 'cd $(@D) && make install'
27endef
28
Patrick Williams01f14c82014-12-11 19:03:42 -060029$(eval $(host-generic-package))