blob: af7c88b9196ec8ce300f6e41595811a9511c19d7 [file] [log] [blame]
Nick Bofferdingf390b6f2019-10-08 11:55:42 -05001################################################################################
2#
3# Hostboot for POWER10
4#
5################################################################################
6
7HOSTBOOT_P10_VERSION = $(call qstrip,$(BR2_HOSTBOOT_P10_VERSION))
8# TODO: WORKAROUND: Need to reenable next line and comment out the two lines
9# after that, when code is propagated to a public repo
10#HOSTBOOT_P10_SITE ?= $(call github,open-power,hostboot,$(HOSTBOOT_P10_VERSION))
Nicholas E Bofferdingbf4fdae2019-11-14 00:00:33 -060011HOSTBOOT_P10_SITE ?= git@github.ibm.com:open-power/hostboot.git
Nick Bofferdinge2293ba2019-11-14 14:38:29 -060012HOSTBOOT_P10_SITE_METHOD ?= git
Nick Bofferdingf390b6f2019-10-08 11:55:42 -050013
14HOSTBOOT_P10_LICENSE = Apache-2.0
15HOSTBOOT_P10_LICENSE_FILES = LICENSE
16HOSTBOOT_P10_DEPENDENCIES = host-binutils
17
18HOSTBOOT_P10_INSTALL_IMAGES = YES
19HOSTBOOT_P10_INSTALL_TARGET = NO
20
21HOSTBOOT_P10_ENV_VARS=$(TARGET_MAKE_ENV) PERL_USE_UNSAFE_INC=1 \
22 CONFIG_FILE=$(BR2_EXTERNAL_OP_BUILD_PATH)/configs/hostboot/$(BR2_HOSTBOOT_P10_CONFIG_FILE) \
23 OPENPOWER_BUILD=1 CROSS_PREFIX="$(CCACHE) $(TARGET_CROSS)" HOST_PREFIX="" HOST_BINUTILS_DIR=$(HOST_BINUTILS_DIR) \
24 HOSTBOOT_VERSION=`cat $(HOSTBOOT_P10_VERSION_FILE)`
25
26# TODO: WORKAROUND: Currently the git clone causes a bad symlink
27# to be created for src/include/usr/tracinterface.H; so delete it and rebuild it
28# manually
29define HOSTBOOT_P10_BUILD_CMDS
30 $(HOSTBOOT_P10_ENV_VARS) bash -c 'cd $(@D) && rm -f src/include/usr/tracinterface.H && cp src/include/usr/trace/interface.H src/include/usr/tracinterface.H && source ./env.bash && $(MAKE)'
31endef
32
33define HOSTBOOT_P10_INSTALL_IMAGES_CMDS
34 cd $(@D) && source ./env.bash && $(@D)/src/build/tools/hbDistribute --openpower $(STAGING_DIR)/hostboot_build_images/
35endef
36
37$(eval $(generic-package))