SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc." | |
HOMEPAGE = "https://github.com/aio-libs/multidict/" | |
LICENSE = "Apache-2.0" | |
LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a" | |
SRC_URI[sha256sum] = "25b4e5f22d3a37ddf3effc0710ba692cfc792c2b9edfb9c05aefe823256e84d5" | |
inherit pypi setuptools3 ptest | |
SRC_URI += " \ | |
file://run-ptest \ | |
" | |
RDEPENDS_${PN}-ptest += " \ | |
${PYTHON_PN}-pytest \ | |
" | |
do_install_ptest() { | |
install -d ${D}${PTEST_PATH}/tests | |
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | |
} | |
BBCLASSEXTEND = "native nativesdk" |