| DESCRIPTION = "Parser for the Compose file format (version 3)" |
| HOMEPAGE = "https://github.com/aanand/compose-file" |
| SECTION = "devel/go" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=9cd86830b557232ce55e2a6b47387471" |
| |
| SRCNAME = "compose-file" |
| |
| PKG_NAME = "github.com/aanand/${SRCNAME}" |
| SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}" |
| |
| SRCREV = "a3e58764f50597b6217fec07e9bff7225c4a1719" |
| PV = "3.0+git${SRCPV}" |
| |
| S = "${WORKDIR}/git" |
| |
| # NO-OP the do compile rule because this recipe is source only. |
| do_compile() { |
| } |
| |
| do_install() { |
| install -d ${D}${prefix}/local/go/src/${PKG_NAME} |
| for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do |
| if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then |
| mkdir -p ${D}${prefix}/local/go/$(dirname $j) |
| fi |
| cp $j ${D}${prefix}/local/go/$j |
| done |
| cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/ |
| } |
| |
| SYSROOT_PREPROCESS_FUNCS += "go_compose_file_sysroot_preprocess" |
| |
| go_compose_file_sysroot_preprocess () { |
| install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} |
| cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) |
| } |
| |
| FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" |
| |
| CLEANBROKEN = "1" |