| SUMMARY = "Python project template generator with batteries included" |
| DESCRIPTION = "PyScaffold package helps to setup a new Python project. \ |
| After installation, it provides a new command [putup], which could be \ |
| used to create template Projects." |
| |
| HOMEPAGE = "https://github.com/pyscaffold/pyscaffold" |
| SECTION = "devel/python" |
| LICENSE = "0BSD & MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=14a49c74a1d91829908ac756c07e6b91" |
| DEPENDS += "python3-setuptools-scm-native" |
| |
| SRC_URI[sha256sum] = "50cb1f910163204caec30c7c6bbe70f1a81c377538b8c8340d23abe31f5ca5b4" |
| |
| inherit pypi python_setuptools_build_meta |
| PYPI_PACKAGE = "PyScaffold" |
| |
| RDEPENDS:${PN} += " \ |
| python3-email \ |
| python3-compression \ |
| " |
| |
| BBCLASSEXTEND = "native nativesdk" |