| SUMMARY = "Perl interface to the zlib compression library." |
| DESCRIPTION = "The Compress::Raw::Zlib module provides a Perl interface \ |
| to the zlib compression library (see 'AUTHOR' for details about where to \ |
| get zlib)." |
| HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Zlib" |
| SECTION = "libs" |
| LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| |
| LIC_FILES_CHKSUM = "file://README;beginline=8;endline=17;md5=603fa463887aed6bb3f6f2a999aca775" |
| |
| SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Zlib-${PV}.tar.gz" |
| |
| SRC_URI[md5sum] = "4144ecdd901231553447998cf8035e4a" |
| SRC_URI[sha256sum] = "cd4cba20c159a7748b8bc91278524a7da70573d9531fde62298609a5f1c65912" |
| |
| DEPENDS += "zlib" |
| |
| S = "${WORKDIR}/Compress-Raw-Zlib-${PV}" |
| |
| inherit cpan |
| |
| export BUILD_ZLIB="0" |
| |
| do_compile() { |
| export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| cpan_do_compile |
| } |
| |
| BBCLASSEXTEND = "native" |