| DESCRIPTION = "Very fast, header only, C++ logging library." |
| HOMEPAGE = "https://github.com/gabime/spdlog/wiki" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| |
| SRCREV = "a7148b718ea2fabb8387cb90aee9bf448da63e65" |
| SRC_URI = "git://github.com/gabime/spdlog.git;protocol=git;branch=v1.x;" |
| |
| S = "${WORKDIR}/git" |
| |
| BBCLASSEXTEND = "native" |
| # no need to build example&text&benchmarks on pure yocto |
| EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_EXAMPLES=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off" |
| |
| inherit cmake |
| |
| # Header-only library |
| RDEPENDS_${PN}-dev = "" |
| RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |