| SUMMARY = "Simon Tatham's Portable Puzzle Collection" |
| DESCRIPTION = "Collection of small computer programs which implement one-player puzzle games." |
| HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/" |
| LIC_FILES_CHKSUM = "file://LICENCE;md5=92d2b7a2fc96b5f7f17101df7db1fefa" |
| # gtk support includes a bunch of x11 headers |
| REQUIRED_DISTRO_FEATURES = "x11" |
| SRC_URI = "git://git.tartarus.org/simon/puzzles.git;branch=main" |
| UPSTREAM_CHECK_COMMITS = "1" |
| SRCREV = "7364ce8e266d947be146d635958a7b282752aac6" |
| inherit cmake features_check pkgconfig |
| # net conflicts with Samba, so rename it |
| mv ${D}${bindir}/net ${D}${bindir}/puzzles-net |
| rm ${D}/${datadir}/applications/net.desktop |
| # Create desktop shortcuts |
| install -d ${D}/${datadir}/applications/ |
| # Convert prog to Title Case |
| title=$(echo $prog | sed 's/puzzles-//' | sed 's/\(^\| \)./\U&/g') |
| echo "making ${D}/${datadir}/applications/$prog.desktop" |
| cat <<STOP > ${D}/${datadir}/applications/$prog.desktop |