| SUMMARY = "msmtp is an SMTP client" |
| DESCRIPTION = "A sendmail replacement for use in MTAs like mutt" |
| HOMEPAGE = "http://msmtp.sourceforge.net/" |
| SECTION = "console/network" |
| |
| LICENSE = "GPLv3" |
| DEPENDS = "zlib gnutls" |
| |
| #COPYING or Licence |
| LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| |
| SRC_URI = "http://sourceforge.net/projects/msmtp/files/msmtp/${PV}/${BPN}-${PV}.tar.xz \ |
| " |
| |
| SRC_URI[md5sum] = "3baca93c7e5f1aa9d36a2e5b38739ab9" |
| SRC_URI[sha256sum] = "2f6ecd7cbfadf548fd55205bd24cb63b84bcbb1185efed917dd7800595a48789" |
| |
| inherit gettext autotools update-alternatives pkgconfig |
| |
| EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn" |
| |
| ALTERNATIVE_${PN} = "sendmail" |
| ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp" |
| ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail" |
| ALTERNATIVE_PRIORITY = "100" |
| |
| pkg_postinst_${PN}_linuxstdbase () { |
| # /usr/lib/sendmial is required by LSB core test |
| [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/ |
| } |