| # note that we allow for us to use data later than our code version |
| # |
| SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect" |
| LICENSE = "PD & BSD & BSD-3-Clause" |
| |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=76ae2becfcb9a685041c6f166b44c2c2" |
| |
| SRC_URI =" ftp://ftp.iana.org/tz/releases/tzcode${PV}.tar.gz;name=tzcode \ |
| ftp://ftp.iana.org/tz/releases/tzdata${PV}.tar.gz;name=tzdata" |
| |
| SRC_URI[tzcode.md5sum] = "f5e0299925631da7cf82d8ce1205111d" |
| SRC_URI[tzcode.sha256sum] = "11ae66d59b844e8c6c81914c9dd73b666627bd7792855ba9de195eee4520c28d" |
| SRC_URI[tzdata.md5sum] = "0d3123eb1b453ec0620822bd65be4c42" |
| SRC_URI[tzdata.sha256sum] = "5efa6b324e64ef921ef700ac3273a51895f672684a30e342f68e47871c6a8cd1" |
| |
| S = "${WORKDIR}" |
| |
| inherit native |
| |
| do_install () { |
| install -d ${D}${bindir}/ |
| install -m 755 zic ${D}${bindir}/ |
| install -m 755 zdump ${D}${bindir}/ |
| install -m 755 tzselect ${D}${bindir}/ |
| } |